Passport for Mac does not complete backup

When I try to run backup I get this message:
Backup Failed. Time Machine couldn’t back up to “My Passport for Mac.”
But when I open Time Machine I see that a lot of data has been backed up.
Time machine repeatedly displays "Backup Failed message.
I’m on iMac running OS 10.14.1 Passport software is installed and up to date.
WD Utilities says passport drive is okay.
What am I doing wrong?

1 Like

Hello simonyoung,

Are you getting same error message with another version of Mac computer during the Time Machine backup on My Passport for Mac drive?

Yes, I erased/reformatted My Passport (while in OS 10.14.1), and restarted the backup.
It seemed to be working - though very slowly - for hours.

When I woke up this morning, I had the same error message, and the drive was empty.

Any suggestions?

simonyoung

In new macOS 10.14 (Mojave), some issues are causing with Time Machine while taking backup on external drive and My Cloud network devices. I hope, Apple would fix it soon.
Did you try to check it on another macOS version computer such as Sierra or High Sierra for same issue?

No I haven’t. Perhaps I should call Apple, and see what they have to say…

Having same problem with 10.14.1. It was working fine until mid-October, then a couple times it has said a last back-up date in the last 30 days. Others, same back-up failure message because of “error.” This is my only Mac so I can’t try on an earlier OS unless I try to uninstall Mojave and go back to the earlier version.
Any thoughts? Thanks.

I have two My Passports, one is 2TB and the other is 4TB, Neither of them will complete a backup since the Mojave upgrade. I have tried reformating my 2TB several times but it doesn’t work. Now it tells me it has failed to complete the first backup. The advice from WD is to format Mac OS extended journaled and I have done this twice now.

Hello, just wondering if you manage to solve the issue? I’m having exactly the same problem, it did a backup after upgrading to Mojave but then suddenly it stopped and fails to complete the backups.

I have run the disk manager utility and the disk show no problem

No I did NOT solve the problem. Returned the item to the vendor for refund, and then ordered a different drive from another source.
And guess what happened? The same damned thing - wouldn’t complete the backup! So the second vendor told me to return it, and I am waiting for a replacement or an explanation (whichever comes first). My suspicion is that the problem is with Mojave - and I have no clue what to do about it. Any ideas?

I solved the issue by going back from Mojave to High Sierra and the WD drives are working normally again. Mojave is the problem

I just ordered another drive and I can tell you it is not a WD drive.

[Solved!]

I had exactly the same problem - no matter how many times a I rebooted my Mac or reformatted my WD drive, the first Time Machine backup would succeed and any subsequent one would fail with “Error occurred while creating the backup folder”. It took 3 calls to Apple Support, but they have solved it for me. I had my first complete backup yesterday, and about 20 successful hourly backups since then.

My setup: A new (2019) MacBook Pro 15" running Mac OS Mohave (10.14.5) with a new 4TB WD My Passport.

Steps Apple Support took me through to fix this:

  1. Get into Repair mode by powering down your Mac, then immediately after pressing the Power button to turn it back on, press and hold Command-r (⌘+r) for a while, until the Mac does NOT show a booting scroll bar, but instead asks you a question or two like “Language?” Note you must power down, not just Restart, since you can’t do Command-r fast enough during a Restart.

  2. Once in Repair mode, you will be shown a list of 4 choices. Select Disk Utility. It looked to me like the same Disk Utility you could get at without Repair Mode but you have to be in Repair Mode.

  3. Select your primary disk (usually Macintosh HD) and click on First Aid. For me this took 4 minutes and ended with a green check mark that everything was fine. I don’t know what you should do if your results vary.

  4. Select the External WD disk you want to use for backup and click on Erase Disk (presuming you want to use the entire disk as your backup - if not you’ll need to call Apple for different directions). Pick a name and you want to format as “APFS” (not encrypted or case sensitive) with GUID Map. That was very quick.

  5. With the external WD drive still selected, click on First Aid and say OK to erase disk. This was also very quick and also ended in a green checkmark. Again, if your results differ, talk to Apple.

  6. Exit the Disk Utility and reboot.

  7. Start up Time Machine, remove your existing backup disk selection (especially if it is the disk you were just erasing), and re-select the external WD disk you just did First Aid on as your backup disk.

  8. Let the first backup complete. Wait for a while to confirm that subsequent backups have also completed successfully. I waited 24 hours and when I went into TimeMachine there were about 20 successful hourly backups waiting for me.

I asked why First Aid would solve the problem, and was told First Aid was not just a checking tool, it also silently fixes minor incompatibilities. Whatever the issue is that Apple + WD have do get fixed by First Aid. Note that we ran First Aid on both the Apple internal drive and the WD external drive to get them into the same state. Minor point of interest - my internal drive is encrypted, but my external drive is not. Before the First Aid fixes, I was getting a warning about this. I no longer do.

I hope this helps everyone else on this thread.
Mark Batten-Carew

Hey Mark,
I cannot believe it but your instructions worked-like a charm! I’m not very techie, I can’t believe that I was able to follow them as they seemed intimidating at first. But you wrote them out so clearly, it was actually pretty easy. Thanks so much!

Connie

Omfg Mark, you Saint! You completely saved my sanity and probably my life’s work. I gladly redirect an entire year’s worth of good karma in your direction. Thank you, thank you, THANK YOU!!

I’m having the same backup issue. My 2TB My Passport has backed up faithfully to Time Machine for many years (6-7?). I bought another 2TB 6 months ago and it was faulty so I just bought a 4TB My Passport and get the error message “Unable to complete backup. An error occurred while creating the backup folder.” I followed your instructions and was able to backup! However, every backup try since then fails with the same message. I am left with one complete backup but nothing since. The old 2TB continues to work fine.