Error Message "Invalid request. (404). Unable to log in to My Cloud from Android

I have not been able to login to My Cloud on my local wifi network from an Android device. Neither my tablet or smartphone with the latest android software will allow me to login. I can log in on my data connection however, and my desktop computer has no problems. I get the error message “Invalid request. (404)".

The Dashboard shows all devices connected to My Cloud, and the software sees the hardware, but will not log on.

I have reinstalled the android software, deleted all connections and reconnected in the settings software. I have reset the password, and rebooted the drive. Not sure what else to try.

Thanks for any help you can give me.

what FW version?

are you letting the mycloud app scan the network? Or are you trying somthing else?

have you tried generating a 1 time cde on the mycloud and using that?

has it ever worked?

what “settings software”?

what FW version?

Not sure what you mean by FW

are you letting the mycloud app scan the network? Or are you trying somthing else?

I am trying to access mycloud from my mobile device on my local wifi network.

have you tried generating a 1 time cde on the mycloud and using that?

Yes. I am able to see the mycloud on my device, but when the software tries to logon, I get the error message.

has it ever worked?

It has worked perfectly up until the new firmware update.

what “settings software”?


FW is firmware

Have you deleted the myclould in the app then add it back?

The 1time code is generated in the dashboard. Not by seeing in the network

Firmware is the latest. Automatic upload and install Oct 6. 

Yes, I have deleted the My Cloud from the software and and reconnected with access code generated by dashboard utility.


i keep getting this error when trying to conect my lenovo tablet  

i have instaleed an unistelled the android app twice and still get this error both of our iphones are fine along with our laptop and ipad air and a remote logon on my friends pc up country

its driving me mad LoL


Hi All,

I’ve just bought this device and I have the same problem.

Just wondering if the WD team knows about this issue.

Or has anyone found the solution to this?

I have had lengthy email conversations with them and have tried every possible reset, reinstall, reformat, regurgitate. No go.
I think I finally have them convinced that the Android software will not handshake with the firmware. I told them to look at how it works with WD Photos, as that software still works.
They said they would, so will let you know if they get it to work.
Judging by the the number of comments in the store, it is a common problem.
I have found other file software that will will do the job just about as well as WD My Cloud. It still works remotely.
Web page access doesn’t work with units that can’t do flash.

We have passed this information to the support teams.


I have the same problem with a new 4gb WDMyCloud. Neither my S3 or Galaxy TabPro will work with the Android app. It recognizes the device but then give the Invalid Request (404) message every time.

Makster wrote:

I have found other file software that will will do the job just about as well as WD My Cloud. It still works remotely.

Could you specify what you used and how you got remote working please? I understand that any file management sw will do the job while connected to the LAN, but I want to be able to connect remotely as well and I have no clue how to do that without the app.

Thanks for any help.


Brand new, clean install of a 4TB MyCloud device, fresh download of the ap from play store onto a Samsung Note S3 and Relay 4G, and I’m having the same issues from within my local protected network, connected wirelessly through either phone.  Since the HTTP 404 status is something that’s set/returned by the web server (MyCloud box in this case), then it’s pretty obvious that the problem is in one of two places:  Either the android ap is sending malformed/garbage http requests to the MyCloud server that reference non-existent URL’s, or the server software in the MyCloud box is broken.  In either case, this is a WD problem.

The Android WD MyCloud works fine outside my network.
I recently needed to reset my operating systems. Deletion of cash and data allowed connection… for a short time. Wasn’t long before same error started to occur. I have advised WD about this development, but to date they have not advised of a fix.
I don’t use the software much inside my network, so not a big deal for me. As long as I can access on the road, I am fine.
Not sure how to resolve no access outside a network. I will experiment with some other software and let you know if I am able to connect.
Meanwhile, go WD go!

Hi, I have found solution for this error in my mobile. 1) on my mobile phone with android - I’ve turn on Internet only via gsm - problem with access to mycloud doesn’t exist, I have access. 2) I’ve turn on Wifi on my phone 3) turn off Internet via GSM (only wifi is still active) 4) all works fine After restart application (relogin) via Wifi - still works. please try this on your phones.

Ok folks, it seems WD has solved the issue with the new firmware update. I installed, and voila, no logon error!
Thanks to all who tried to help with this.
Good on WD for fixing it.
Best in the New Year to all.


Ive got the latest firmware installed and im still getting the 404 error on my partners tablet.

I can access the drive on my smartphone no problem, both devices are connected to my home wifi of course.

I am also unable to access the drive at all remotely when not connected to my home wifi.

3G/4G from my handset will not connect, (error 905).

Im yet to try connecting to the drive away from home with my laptop from another wifi source.

Im extremely frustrated with the WD My Cloud as so far it will not function as its intended.


You are right. It still doesn’t work on my Note 8 tablet either. As I mentioned it does now work on my Note 3 since the recent firmware upgrade.

I have never had a problem with access outside my home network or on LTE. However I have not tested other wifi networks to see if anything has changed. I know that my handheld still works on the data side.

As far as I was aware, the problem was with the handshake within the home network and had not heard of anyone having a problem outside the network. Wish I could help you with your other issues, but don’t know what to suggest.

I have also tried all of the fixes that WD sent me, but nothing they suggested ever worked. Obviously they are working on it, but it would seem they have more work to do.

I will also pass on my concern to WD with the tablet issue so they know you are not the only case. 

Sorry you are having so much trouble. Up until recently my device ran perfectly. Not sure how it could have gotten messed up,  but WD is going to have to fix it soon or start losing sales. Not sure I would recommend it to anyone at this point.

Good luck.

I had this problem all latest versions of firmware and app at the time of this posting.

I was able to fix it by turning the “cloud access, remote access” off and then back on in the “general settings”.

Had same issue here.

Only way I’ve found to resolve on my HTC One M8 is make sure app is fully closed, delete data in app settings. On WD Dashboard turn off cloud access>Remote access - had to click this twice to make sure was off. Once this is done then open app on HTC and re-login> this turned cloud access back on automatically - you can see this on WD Dash webpage while logging in.

Good luck

Well, let the heaven’s gate be opened to all. IT WORKS!
How on earth did you figure that out? My hat is off to you.
Please advise WD, as they need to include this in their help solutions. Many are having this issue and they have not been able to advise us as to how to resolve it.
Many thanks.

It was a bit of trial and error. Helps I have decent 4g speed in house so no waiting on pages refreshing. 

Not bad as my first post… Glad I could help. Hope others manage to resolve their problem as well. No idea how to send to WD as a solution.

1 Like