Error after upgrading to Windows 10

MyCloud was just fine with my computer (Windows 8.1) but after I upgraded the same computer to Windows 10, the computer can no longer recognise it on the network.

It is still reachable through the internet IP I can use the dashboard but it cannot be recognised by the computer.

The WD discovery tool does recognise the networked Mycloud but the windows that pops up shows the Map and Browse Network options in gray color (inactive).

Any suggestions? ?

The device has been suddenly recognised. I did not do anything special.

I think I saw many people having the same problem. The computer won’t see the device then suddenly it does.

Good to see it fixed itself.

One setting that can block Windows 10 from seeing the WD My Cloud and other devices/computers on the network is the “network location type”. During the upgrade or install to Windows 10 one may not quite understand what they are reading when, or if, asked which kind of network they are connecting to. If they select “no” on that particular screen (example below), Windows 10 will block access to certain local devices possibly including the WD My Cloud. The following link gives a general overview of the issue and ways to fix it if one made the wrong selection: Change network location type (Public or Private) in Windows 10

You are right. I also posted here a seperate thread on the trick that solved the problem.

Thank you!