Easy method to downgrade to previous version of the firmware

Turns out my optimism was misplaced.  Safepoints still failing even on the downgraded firmware.

Sorry WD but this pile of junk is going back to Amazon.  MyCloud is a nice idea but it doesn’t work.

Never buying WD again.

1 Like

Wow! Wow! Wow! What a difference, many thanks to the OP. This thing has been driving me insane for 6 months. I’ve lost count of all the times I’ve reset, switched off indexing scans, factory reset and re copied all my data. After the last firmware update it was taking me 14 minutes to get the web page loaded and now it’s 3 seconds. And this is with 2.8TB of data on the thing. And it indexed it all in 6 hours. Unthinkable with V4 firmware.

This is how this product should be. I’m also now getting 50-60mb uploads and 80-90mb downloads from it not to mention I can also see how much space I’ve got left. I can also remote into it and have itunes and media streaming enabled.

Something tells me that WD need to go back to the firmware drawing board and see why v3 is so good and v4 is pants. This firmware roll back was applied whilst I had 2.8TB of data on the drive and the difference is just amazing.

This is now the product I wanted which proves that the firmware is what is causing all these problems. And before anyone says about a warranty, I couldn’t really care. All I wanted was a product I could use, It isn’t too much to ask is it? I was ready to cannabalize it and take the drive out to use in an external enclouse anyway. We should be charging WD for our wasted time trying to get this product to work. I’ve probably wasted in excess of 60-70 hours when this solution fixed all issues within an hour.

Well done OP. Are you listening WD?

Don’t get too excited - mine still wouldn’t reliably create and update safepoints even on the old firmware.

(Sent it back as faulty for a refund)

I don’t use the feature so I’m not that bothered. I’m just pleased to have a useable product after 6 months of pain.

I Have just registered to say a very big thank you to the guy who started this post, I have had my 2TB cloud since January this year.

I have found it to be a very good unit apart from not be able to get the safepoint to work.

Like others I updated the firmware as soon as I switch the cloud on thinking this would be the right thing to do, but please please do not do this V4 is rubbish and WD should be ashamed they have not sorted it by now.

I followed the instruction given and downgraded the firmware to V3, now everything is working fine for me.

Lets hope WD do something about the firmware before long.

Anyway a big thank you to the man at the top of the post


Hi guys,

its very good you write that old firmware is OK, I want it too, but I have problem by downgrade. The problem is that MyCloud always notices “Device does not have enough space for upgrade.” I tried it update from file from my PC and MyCloud public share folder too, but no one works. I rebooted many times. Do you have any ideas how to solve this?

Thanks for your help!

If you look on the dashboard main page you will probably see that the remaining capacity of the MyCloud is not being reported. It is probably endlessly scanning all your data. This is causing your problem. There are some posts on this (search for “capacity” ) and doesn’t seem to be resolved. The first thing to try is to turn off media server and iTunes server and then reboot. If that doesn’t work, try a system restore (press the reset for 40 seconds). As soon as comes online turn off the media server and iTunes server again. You may have to leave it for a while until the device stabilises and has calculated the remaining capacity.

Thanks for your answer dubie! You are right that cloud doesn’t show remaining capacity. So I turned off media and itunes server, rebooted and nothing changed. So I made a system restore, turned off media and itunes server again, rebooted and tried update firmware from a file many times, but cloud notices still the same message “Device does not have enough space for upgrade.”

I dont know how to downgrade firmware, cloud is with new firmware useless:-(

I had this problem and tried multiple re-boots and system resets but had no success. I finally solved the capacity issue in the dashboard by turning off the DNLA and itunes media servers and then rebuilding the content database. I’m not 100% sure if this was the solution. Perhaps it was coincidence. Nevertheless it is worth a try.

See under: General - Cloud Access - Configure - Content Database - Rebuild

As I said before you may need to leave the device for a day or so to stabilise.

If this doesn’t work you could disable the media scanning service if you are confident to SSH into your MyCloud. You should do this anyway after you manage to downgrade the firmware.

See this post:

the not as easy method worked for me.


Thank you for your aswers dubie and lotust251!

I had always problem with media scaning, so I tried tutorial from lotust251’s link. It’s written great, thanks for it.

Now I downgraded to v030401-230 firmware and cloud seems to be in very good condition, fast good response, everything seems to be OK:-) Thanks you once again for your help.

But I have problem when I connect to Cloud my USB disc WD MyBook. After while Cloud doesn’t response. The response stops after I want to load and see my previous safepoints from USB. Without USB Cloud works OK. I will try to solve it next days, but if you have some ideas I will be very happy. 

I have had the same problem since day 1. Doesn’t matter which firmware version I use, if I connect the My Book via USB to the My Cloud, the My Cloud drops off the network.

glad I could help.  This is what a good forum does.   help each other 

Nice that you successfuly downgraded the firmware. Now, I recommend you perform a “system only restore” from the dashboard under Settings - Utilities. Again, turn off media scanning and itunes server once it boots. Make sure the USB drive is disconnected first. It would be a good opportunity to wipe all the hidden files and kill the media scanning services as I mentioned in my previous post.

Before you connect the USB drive to the MyCloud again, plug it into your PC and check the disk for errors.

I did the downgrade with no problems. But if wha you said cant hurt to do. Definity make sure the drive is off.

General rule of thumb is for one to load up the Mycloud with your data slowly. I had 2tb of pics and movies and music. I had the media server on the whole time. I drive indexed and made thumbnails for 4 days! lol seriously.

Thank you for your answers guys. As I wrote before I had still problems after successful firmware downgrade – problems after connecting USB disc with cloud response and updating my previous safepoint. So I realized some advices from dubie and cloud now works very good :smiley:

First I made system restore only, after that I stopped media and itunes server and restarted. Through this I checked my USB WD MyCloud on PC – everything was OK. At first it didn’t help but after 2nd restart and waiting a few minutes after start it was good and cloud worked with USB disc correctly - I saw previous safepoint and I updated it manually and in the night automatically too. I used cloud for 3 days and I successfully updated safepoint again with no problem and response is OK. It appears that everything is OK – now I see the remaining capacity, safepoints, I have access with wd2go.com and from smartphone app WD my cloud (only WD Photos doesn’t work). I can recommend and help with this procedure everybody who has similar problems.

But I want ask some other things. I want use DLNA media server with my TV and itunes server with itunes app. What do you think, when I turn these servers on, will also cloud work correctly?

And I didn’t do one thing, I didn’t wipe all the hidden files and kill the media scanning services as dubie recommend on http://community.wd.com/t5/WD-My-Cloud/Hidden-wdmc-directories-created-by-mcserver-and-photodbmerger/td-p/682091. I admit that I didn’t understand the aim and what will happens when I do this. Does it influence media and itunes servers? I know this is the other theme it will be better I write there, but I will be very happy if you can simple explain me the aim of deleting the .wdmc hidden folders and disabling wdmcserverd and wdphotomergerd.


There is a nice explanation from Raphael about the media scanning service in his post here: http://community.wd.com/t5/WD-My-Cloud/before-you-pack-up-your-WD-and-return-it-let-s-talk-about/td-p/683307

You have to scroll half way down the first post to the heading " Finally the problem with WD Cloud"

I’m not so sure about using Twonky and itunes. I have turned these off as I do not need them. Hopefully someone else will answer.


I tried to downgrade the firmware to the version suggested in this post, but it fails saying:

Upload firmware fail. Try again.

I tried, but the result is the same. One thing I’ve noticed is that after I change the version in the version file and reboot the device, the version number is restored to the original one (1.05.30). After that attempt to download the sq-030401-230-20140415.deb file to the device fails with the error above. Any suggestions?

Are you sure that you unzipped the firmware deb file after you downloaded?

1.05.30 firmware is for the My Cloud Mirror.  WD took back my My Cloud and gave me a My Cloud Mirror and I am not seeing any issues with backups or connecting my 3TB My Book (used to crash the My Cloud).