Easy method to downgrade to previous version of the firmware

Do you mean pulling the power plug for 40 seconds or something else?  I did pull the power cord but not likely for 40 seconds.  That quick power down and reboot didn’t do anything.

For the 40 second reset you need to remove the power and hold in the reset button through the hole in the backpanel with a straightened paperclip or something similar then reapply the power while continuing to hold the reset button for 40 seconds (you almost need to be a contortionist to do this ) after 40 seconds you can release the reset button and the cloud will reinitialise and once this is complete all should be well with the dashboard.

1 Like

OK, that allowed me into the Dashboard but it took about an hour.  However, it wiped out all the users (not the data files) and I had to set that up again.  I will let you know if this solves the Safepoint.

Well, after I got everything setup again, I attached my 3TB My Book to the USB3 port on the My Cloud.  I was able to see the My Book and used Windows Explorer to delete a folder from an old failed Safepoint. It started to delete but then the My Cloud fell off the network. I pulled the My Book USB cable and rebooted the My Cloud via the power cable.  I’ve done that twice now and can see the My Cloud from Windows Explorer but the dashboard is just a white page, no attempt to connect.  My Cloud remote is the same from both my laptop and cell phone.

EDIT: My Cloud remote started working after quite awhile.  Also, for some reason double clicking the My Cloud dashboard icon on my desktop has removed the “/UI/” from the end of the log on.  When I manually added that, dashboard connected.  Strange.

EDIT 2: Reconnected the My Book and the My Cloud and Windows Explorer immediately says My Cloud can’t be opened but dashboard is still working and shows the My Book under USB.  Network lists the My Cloud but says network path not found.

EDIT 3: Rebooted and then attached My Book to my laptop. Setup a safepoint using WiFi. The safepoint failed a few minutes later with code 1100 and the safepoint name was deleted from the safepoint list.  This is exactly what I saw with v4.x firmware.

EDIT 4: Made sure that there were no files at the root level of the My Book (i.e., moved anything on the drive to a single folder). Rebooted the My Cloud and my laptop.  Setup a new Safepoint and it has been running for a couple of hours (5.6GB) without a crash.  Fingers crossed.

EDIT 5: Got to 12GB and then:

Following events are generated on your WDMyCloud .

Event title:There was an error creating your safepoint.

Event description:2 - There was an error creating your safepoint WiFiTest on the E share on WWK764-PC.

Severity:warning

Event code:1100

Event time:02-02-2015 03:22:17 PM

Firmware version:       03.04.01-230

EDIT 6: Same results with both versions of firmware.  This isn’t worth any more of my time and will see if I can stick Amazon with a refund on both the My Cloud and My Book.  It isn’t automation if you spend a man-week trying to make it work.

Thank you! Thank you! Thank you!

With firmware 4.x I could not use safepoint, dashboard was slow, and no cloud access.

I followed your instructions and aside from having to do a 40 second reset it worked.  My dashboard is now snappy and the safepoint is working in both manual and auto now.

I would recommend to anyone considering this:

Use the dashboard to eject any attached USB device first then disconnect and power down the attached drive.  Wait until you have completed every step in the intialization process and performed a complete shutdown and restart of the cloud before trying to re-attach any USB device.

Thanks again.

Stealth57

Mate, sorry to hear your having so much trouble… Ive been reading what your going through and to be honest, your symptoms sound exactly the same as I was getting with the 4.xx firmware and hence found this page and downgraded… !!

Is there any chance your downgrade hasn’t worked?? Because it sounds like the same **bleep** the v4 firmware produced in my setup…

Is there any way you can re-apply the downgrade or check the firmware version at least?

Jim

Dashboard says v3 but is that real or just reading what I entered via winscp? I agree that it acts the same as v4.

OK, you may be right about the version number…

personally, I would start from the beginning and try again!! At this point, what have you got to lose?

(Don’t want to teach you to **bleep** eggs but)

Follow the instructions to the letter, and downgrade as if for the first time…

Jim

Update 1: I reinstalled v3 firmware and this time the dashboard worked without the 40 second reboot.  I then attached the My Book to the My Cloud and the My Cloud remained on the network; something it never did before.  Both are visible in Windows Explorer and also in the My Cloud remote software.  Since the My Book defaulted to “public,” I am letting the My Cloud finish scanning the My Book for media files before I try a Safepoint.  I think I will leave the My Book public until I test the Safepoint and if that works, then restrict access by user.

Update 2: The SafePoint is running and at 2.8GB.  A long way to go but it has gotten past where some of the previous SafePoints failed.

Update 3: SafePoint is at 66GB, which is about 30GB/hr.  Best I ever got was 10GB/hr on v4.x and, of course, it crashed before finishing.

Update 4: Crashed at 140GB.  My Cloud stopped responding to the network.

After the reboot, once again the My Cloud has deleted any record of the Safepoint.  Also, when I attached the My Book, the My Cloud immediately dropped off the network.  It was acting fine until the Safepoint failed and now it is acting like v4.x again.  I think I will reinstall the v3.x firmware and this time just forget about setting a Safepoint.

Just wondering why it is written in the first post of this thread that:

When using SSH and Winscp:

“Double click to open the file and change the version name to 03.04.01- 219 and save the file”

But the firmare being installed is sq-030401- 230 -20140415…deb

Is the version naming in SSH important?

Hi dubie

you need to change the version name in the WDMyCloud to fool it into thinking that the downgrade firmware is actually an upgrade hence the 219 which is lower than 230.

also after downgrading I changed the version name to the latest release so that the WDMyCloud thinks it has the latest firmware and does not keep asking to upgrade (this can even happen in the mobile apps when accessing a WDMyCloud with firmware that is older than the latest release)

1 Like

Mine is running the latest version 04.01.02-417.

Its acting the twit and I can’t make any safepoints and it has problem recognising my USB hard drive…

Can I just downgrade in one step to 03.04.01-230?

Tel911,

Do you enter the current 4.x… number in the same place you edited down to 3…219?

Yes that’s right then the new number is displayed in the dashboard

Hi boatbuilder yes it is relatively easy just follow the instructions
Note after downgrading on the last couple of firmwares it seems to affect access to the dashboard and only shows a blank screen this is usually fixed by the 40 second reset which means you will need to reconfigure all of the settings but data and shares will be okay

Brilliant, it seems to have worked perfectly following the instructions in the first post at the beginning of the thread.  Then  I did the 40 second reset and then the UI interface showed up fine.  Data was fully intact, although I took the precaution of making a copy of it all via the network before I tried this!

Had to set up network settings again (I used a static IP) and re-set up the access to devices.

It now recognises my 2TB Samsung 2.5" drive in an Inateck usb enclosure and its in the process of making a safepoint on it, which it totally refused to do on the latest firmware version.   I was just about to send the MyCloud back to Amazon.  I’m hoping WD sort out the firmware problem eventually, surely its just a matter of time?

I am still having issues, even on v3.x.  After the second install, things seemed to going better. I could attach the My Book directly to the My Cloud without it dropping off the network. However, the Safepoint died at 140GB. Since then, I cannot attach the My Book without the My Cloud disconnecting from the network. I have even reinstalled v3.x a couple more times and nothing works. Something must get stepped on that isn’t cleaned up by the firmware install. I am thinking about upgrading to 4.x and then downgrading again.  Any thoughts?

Thanks Tel911, great answer! I already fell victim to the mobile app, so I will tell the MyCloud it has the latest firmware.

In my experience it isn’t enough just to downgrade the firmware. I’ve tried this more than once on two different MyClouds. I have now succeeded by downgrading as per the instructions and then doing a full factory restore. After the MyCloud finishes the Full Restore process I turned off media serving and iTunes server. I had to first manually copy across all my data onto a backup device, then back across to the MyCloud after the Factory Restore. This is a very time consuming process, but at least I can now finally complete regular safe points.