Dublicate shares after reboot

I have contacted the WD support about this and got this answer:

Dear Customer ,

Thank you for contacting Western Digital Customer Support, I am one of the WD Support Agents.

First and foremost, we would like to thank you for taking the time to contact us in regards to the issue with WD My Cloud. I sincerely apologise for any inconveniences that this may have caused you.

I understand that after doing a reboot for the device the share names are duplicated.

I appreciate your feedback about this concern, but as of now you did the correct work around for this , I do hope that rebooting the NAS is not necessary always.

I hope that this issue will be solved with the next firmware update, which I am not able to provide when it is coming.

Duplicate share of what? An attached external USB hard drive?

If you are getting duplicated Share names for attached external USB hard drive there are several prior threads that discuss that particular issue introduced in v04.04.02-105 firmware (and possible the latest v2.x firmware). See these recent threads for further discussion about this issue and some potential workarounds.




it is dublicate shares of already atacked hds and then with power failure or reboot from dashboard
the share name is dublicated but added a number. By the way I just wanted to tell that the team is aware of it.

go into the dashboard and open the shares. delete the shares not working. and rename the last dublicated shre to what you have e.g. Samsung. Avoid to reboot or turn of your NAS

The problem may be that when the reboot or power fail occurs the share info is not correctly handled. When a USB device is mounted. The share name is entered in the /etc/samba/overall_share file. When you eject the USB the share name is removed from the /etc/samba/overall_share file. If the name is not removed when you remount the USB device it will mount it by appending _2 or greater depending on haw many names are in the /etc/samba/overall_share file. You can test this by running “/usr/local/sbin/getshares.sh all”. Using the devices.sh file which was posted in another thread.


PS Bennor I tried the click on the date of a thread. But couldn’t get it to post to this reply

On a Windows PC when one clicks on the time/date on the right top of the post one should get a field that appears with the link to the post. Or one can right click on the time/date and select “Copy Shortcut” (or similar).

if you in dasboard unmount the hd and you then add it again, it will not dublicate the sharename, but keep it. It is only when power fails or you reboot without unmounting the hds the sharenames will be dublicated.

This is really poor. I should have bought a synology nas.2018-01-29 19_06_33-WUDANGSHAN [WD My Cloud EX4 ™]

If its a USB drive Share name that’s being duplicated its a well known and discussed issue with the single bay My Cloud units. See links posted up thread for possible solutions/workarounds to the issue.

Haven’t had this particular issue (USB drive Share duplication) crop up in a good long while after a reboot or a shutdown/power on.

Sad enough, it’s not even a USB drive. It’s the standard fixed drive share on my ex4. I’m now running over 100 duplicates of that share.

Backup the My Cloud and remove all the duplicate Shares then see if the issue continues.

Out of curiosity have you used SSH to change or modify the My Cloud firmware in any way?

You might find someone with experience of the problem on the EX4 forum:


No, standard mycloud firmware here. Did a terminal session over ssh to check the filesystem but no changes.

Honestly, i don’t really consider backup an option since my greatest available volume is the mycloud, which I bought mostly for backup purposes :slight_smile: . Ironic, isn’t it?

@cpt_paranoia: Thanks, looks like i might get some info there indeed.