DS6100 complete re-install

I can not run Essentials in my environment (no domain administrator access.) I have formatted and reinstalled the ds6100 and am trying to install 2012r2 datacenter (site licensed) and can not install some of the wd software due to missing prerequisites. 

Software that will not install (due to not being able to start service):

WDHealthMonitorSetup.exe

WdLcdSetup.exe

WDProductConfigService.exe

WDSoftwareUpdateProvider.exe

WDStorageSetup.exe

The WDSUSetup.exe installed but the webpage does not work (probably because of being unable to install WDStorageSetup.exe.)

The unable to start service error is generic and I believe it is due to .net or other things installed before these are installed (I am currently tearing apart the ALL_os.swm from the recovery partion for more clues.)

PLEASE DO NOT RESPOND THAT THIS IS UNSUPPORTED OR OTHER ISSUES OFF TOPIC

I am looking for help with the prerequisites I am missing to get the above software to install.

I was able to get the above programs to install by comparing the installed features in both the essentials wim and what I have installed on datacenter. So now I can see the marvel/wd drive information from the systray.

I would like the information that is in the essentials dashboard and the lcd panel to work (for some reason the lcdsetup still doesn’t work correctly.)

The error: 

Service cannot be started. System.IO.FileNotFoundException: Could not load file or assembly ‘ProviderFramework, Version=6.2.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ or one of its dependencies. The system cannot find the file specified.
File name: ‘ProviderFramework, Version=6.2.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’
at WdLcdProvider.WdLcdService.OnStart(String[] args)
at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

UPDATE: 
I installed the Windows Server Essentials Experince feature but did not configure it and I was able to successfully install the remaining software. 

Ultimately the version of 2012r2 I am running is irrelevant, my issue is that I do not have Enterprise Admin account access and thereby will never be able to access the dashboard where the WD status information resides. 

Would it be possible to add WD panel to the server manager or run it independently?

I have the same issue except I transmogged to Standard r2 using the YouTube instructional here -  https://www.youtube.com/watch?v=xT67FPfu81A

While yes I was able to get to Standard, the video completely fails to mention that you will totally lose access to the Dashboard so all the WD managment tools are unavailable. So now my DS6100 is stuck in full fan mode with the LED periodically dimming and lighting up.  Uninstalling all the WD ‘progams’ and reinstalling them does not resolve my issue.  

I would also love to join my DS6100 to a domain in our environment, however I’m not a domain admin so I can can’t do that either.  Admiittedly, this seems more of a MS limitation that WD.

I would also like to throw support to unlinking the WD management tools from the essentials dashboard.  Otherwise I’m afraid I’m going to have to send my DS6100 back and look at other options.

Whoever at WD that has Visual Studio on their computer and wrote the class librarys could write a simple wrapper to work the same without the dashboard.

http://blogs.technet.com/b/sbs/archive/2013/09/12/how-to-create-a-dashboard-ui-add-in.aspx

It would be nice if they actually read the forums and wanted to support their product.