Install a valid copy of server 2012 standard on DS6100

I have been trying to install server 2012 standard over the 2012 essential that my ds6100 came with.

I can’t get the unit to boot to the external cd rom that i plugged into a usb port.

How can I install the standard OS over the essential OS?

any help would be appreciated.

I already have an active directory and domain controller.

I just need the unit to function as a share drive/storage server for all of my users.

If you press F7 at boot you will get the menu to pick your DVD.  But I think you will need Raid Drivers to go with those fries :slight_smile:

I think it would be much easier to join it to your Domain and keep the backup/Essentials functionality if you ever wanted to use it

OK I joined our domain…when I try to run Win server essentials, i get an error message that a problem has been encountered. Click retry   can’t get any further than that.

If I don’t run server essentials setup, it won’t let me enter the dashboard

So what do I do next???


Paul Gailey

So it was sitting at configure windows server essentials.  You cancled that, used the native tools to join the domain, reboot and the wizard starts again.

You click next and get an error?  Can you post a screen shot for me? Is the DNS set to your domain controler?

I will try that Wed when I get to work  thank you

Checked DNS…set correctly

still getting the same error…

Can the server essentials be configured if the DS6100 is not set as the prime domain controller and we already have an

active directory? Could that be the problem?

LOL, I was typing this as you sent yours.  Yes it can be a member server.  Now I just joined it to my SBS which is Server 2008R2.  What version is your DC?

Is DNS set to the domain server?  I just did it and all went well.  You are running the wizard that pops up when you reboot.  You are not trying to add the esentials role in server manager. 

You have to show hidden files and folders  programdata\microsoft\windows server\logs\setupcmdlets  (I think)  Look in it for clues or paste it here.

And your first screen looks like this?

Our DC is 2003 R2    old stuff   could that be a problem?

I will check out the rest of your reply


I will check on the 2003R2  May need a schema update or sumthin

OK thanks…I don’t know if I should be calling you Gramps…I will be 68 next month!

My Microsoft MVP buddies started calling me Gramps as they are young twerps and I have been around since they were in kindegarden.  You have me by 10 years though.  I asked the quizzer, we will see what they say.

In the mean time I may see if I can get a copy of server 03R2

thx again…

I think this is you.  You owe Susan Bradley a Mountain Dew :slight_smile:

Let me know

Thanks…I will try this…very busy with other things today…

No worries on my end at all. Just ask that you let us know if you try it and it works so we can all learn from your expertise.


will do…thanks again

Ready to throw this DS6100 out the window…

I was trying some of the fixes you suggested.

At one point, I took the unit off the domain and back to a workgroup.

When I tried to log back in as a workgroup, it will not accept the original password that I set up.

Any suggestions.

Another day or so and this baby is going to be returned…



There was just one fix, Log on as a service? 

Have not been looking over your shoulder but the box is supposed to be in that state where it reboots and logs itself in.  You never set a local password yet that I know of.

Anyway’s try Admin@123   with a big A

that password worked…back in…thanks