DS6100 Baremetal Recovery

Does anyone have a link to an ISO with WD recovery software? The downloads for the DS6100 are severely lacking. The link the support team sent only had a winpe image that recovers from the recover partition. Which of course won’t work when the boot drives are gone. If all else fails can someone capture their R: partition with something like Disk2VHD?

Hopefully an experienced User will be able to assist.

You have tried running the stuff in the firmware download on a clean install?
I see a powershell script in there?

May take me a few days, but I will see what I can do

LOL
Opened the ps1 file. Ben was on the team

Work-around for problem on Ben’s machine where powershell script could not find AddinInfrastructure

Gramps where are you seeing firmware for ds6100? the only firmware I see is for the video driver.

prob same place you are looking. current software on the left is the firmware download

That has some software in it. None of it will work to recover to OEM status. Half of it doesn’t work at all. I was able to get the DS6100 back up and running by installing 2012r2 essentials from technet off a USB key, but none of the WD features, like fan control, lcd display, or wd information panels work at all. In fact the powershell script in that zip does absolutely nothing.

well that’s sad. I thought I saw an old post where you had tried it before. I will see if I can get my box turned on. The LCD says now the server is in standard mode. What is that??? RDP did not work and I do not have a keyboard monitor on it now

I suppose you did run that ps1 script from an admin PowerShell window?

That was when I still had the recovery partition which is gone… :frowning:

if you mean the installaddins.ps1 then that doesnt work at all.

By jove ole boy, I think I got it. This is in a VM. When I get it uploaded to dropbox I will post a link. No clue what version it is yet. Either be prepared to reinstall your server or have a backup. I will take no blame if it goes belly up. Extract all the files to C:\wd and run from an admin cmd prompt WDInstall.bat

Try this

Thank you Gramps!! I wish WD was as helpful and easy to work with as you are!

@Gramps

I just want to be sure I understand the process before I start. I have a valid 2012 R2 license. In order to get back to the factory installed OS:

  1. Unplug RAID drives
  2. I’m going to use a 2012 R2 boot usb with the Marvell drivers added
  3. Install the OS.
  4. Extract files to C:\wd and from elevated prompt run WDInstall.bat
  5. Power off
  6. Plug in drives
  7. Reboot
  8. Continue with configuration

sounds like a plan to me

For some reason every time i see your name I think of this

mmk