DS5100 - OS recovery from backup failed (0x80042414)

Dear experts:

I am trying to recover from system backup of Windows2012R2 essentials on my my DS5100. I did have a complete bare metal backup of UEFI, C drive made from the OS. C drive is WD320GB, and D drive is NAS configured RAID5 disks. I have all the backup, both on OS and data, so it is okay if I lose the data on either drives while recovering.

In order to recover from backup, I inserted the installation USB, launched “repair”, selected the backup from image, then proceeded.

However, I am getting the error message,
“The system image restore failed. Error Details: Windows did not find any disk which it can use for recreating volumes present in backup. Offline disks, cluster shared disks or disks explicitly excluded by user will not be used by Windows. Ensure that disks are online and no disks are excluded by mistake (0x80042414).”

Puzzled by the error, I tried to fresh install the OS from installation USB; when I put the product key, then proceed, the screen shows, “We couldn’t find any drives. To get a storage driver, click Load driver”. No HDD drives are shown where I can install the OS on.

Just to make sure the drives are not dead, when I try to install Linux (CentOS7) on the same setup, the installtion program does recognize all the HDD drives (OS drive C: and data drives D:).

Does anyone have any clue why I am getting the above error (no drives found), and how to proceed with either recovery / or fresh installation? Please advise.

I tried my best to search for this issue in WDC as well as in microsoft community, but could not find the answer.

Thank you very much!

I think this is what you need. Link is supposed to go to dropbox and marvel zip
unzip the files to a folder on your recovery/boot thumb and then do the have disc/load drivers thing

1 Like

Dear Gramps,

This driver worked perfectly. I remember you also helped me back in Jun 2014 when I had another boot failure – thank you so much every time! :slight_smile:

For those who is having same issue – cannot see any available HDD to install Win2012 R2 Essential during installation – can follow Gramps’s guide above. Select load drives, go to the folder where you copied the Marvel drivers into, then hit “browse” button. You will now see the attached HDD to your unit!

Once again, thank you!

Whoop Whoop

Hello Teesdale / Gramps,
I am also trying to perform a clean install of Win2012 R2 Essentials.
I downloaded and created a boot USB and am able to progress through the install (also using the drivers from above - much thanks).
The install seems to work, and triggers a restart. On boot, it detects the Windows Boot Manager, attempts to load the OS, but then I get the following error :

File: \Boot\BCD
Status: 0xc0000034
Info: The Windows Boot Configuration Data file is missing required information

I am at a loss as to what to do, as I have tried another fresh install, as well as rebuild the BCD store manually, using the Bcdedit.exe tool.
Any help would be hugely appreciated. (I am hoping I am doing something idiotic)
R

Let’s hope for idiotic first :slight_smile: You remove the thumb drive when it reboots?
I think I would remove all drives except the drive you are installing to

If it still fails I would do the download again and make a new thumb drive using a different thumb drive

Why are you doing a clean install to start with? You will lose all the WD stuff. Normally you should recover from your backup or second do an image restore from the recovery partition. But to do that you may have to boot into windows.

Hi Gramps,
My boot hard drive failed, and I don’t have a back up (I know this is a rookie error, it was something I was getting to but the drive failed in only a couple months).
I phoned support asking for a recovery ISO but they said I would have to post it in to them -.-" I have googled looking for such an image, but haven’t been able to find one :frowning:

I have tried removing the thumb drive after reboot. Sadly, I still get the same error.
I then redownloaded the OS (from Microsoft as an evaluation), and with a new thumb drive, tried again. Same problem.
I however added the original drive back in, and rebooted, I was greeted with a Windows Automated Repair progress bar, then the Windows 2012 logo, which then disappeared. The LCD screen says “Initializing Ok, Loading UEFI HDD”, and has done for a couple hours.
Any suggestions?
R

So it sat at Loading UEFI HDD for several hours, before I gave up and came back to it.
I have successfully installed Windows Server 2012 R2 Essentials on the server, and it’s back up and running, however as you stated, doesn’t have the Western Digital stuff.
I tried running the installers in the firmware zip, and it’s added some functionality back. In the Dashboard, under Monitor, there is the Software Update tab with the appropriate WD detail, but when I click Update from file and select the appropriate zip, it errors but doesn’t give me detail.
Any ideas or advice?
R

I dunno, I don’t have mine on right now. the loading uefi is because the wd lcd service is not running. Does not reflect any system state actually. You can make it say anything you desire. Are you going to try to use the RAID or just use storage spaces?

If you are bored you can copy below to a bat file

Net Stop “Western Digital LCD Support Service”
c:\wd\lcd.exe 0 “Row Row Row”
c:\wd\lcd.exe 1 “Your Boat”
choice /d y /t 3 > nul
c:\wd\lcd.exe 0 “Gently Down”
c:\wd\lcd.exe 1 “The Stream”
choice /d y /t 3 > nul
c:\wd\lcd.exe 0 “Merrily Merrily”
c:\wd\lcd.exe 1 “Merrily Merrily”
choice /d y /t 3 > nul
c:\wd\lcd.exe 0 “Life is but”
c:\wd\lcd.exe 1 “a Dream”
choice /d y /t 3 > nul
c:\wd\lcd.exe 0 “Have a”
c:\wd\lcd.exe 1 “Koobie Day !”
choice /d y /t 10 > nul
Net Start “Western Digital LCD Support Service”

So where are you now actually? Have the old drive up? You should image the old drive to a new drive and boot to windows with the new drive it and then do the wd image recovery to start clean ?

I wasn’t able to access anything on the boot up drive after multiple attempts, but thankfully have solved all now. Thanks for your help. I have also backed up a system image to Azure just in case this happens again.
For info to anyone :
I used a new drive and installed a fresh Windows 2012 R2 Essentials, but this then did not have the WD components.
I tried installing the components manually that were in the firmware file, but the LCD display wasn’t working, couldn’t see the drive, CPU and fan info in Dashboard, and the fan was full speed.
Tried to open WD Storage Tray, but got an IIS error, and assumed I was missing some .NET installs. I used the “Turn Windows features on or off” option in the control panel to install .NET 3.5/4.5 and CGI. Now the appropriate information is shown in the Dashboard.
Then after looking through the Event Viewer, I saw that a couple of the installs failed as it couldn’t find “C:\WD\Identity.xml”, so I copied the “Identity.xml” file from the firmware zip to that location, and then tried a software update through the Dashboard. This failed. I then tried running “WDSoftwareUpdateProvider.Test” in C:\Windows\Western Digital, which allows you to test updating with a zip, and gives an inline log. This all worked. Fan running quietly, and LCD display showing appropriate alerts and info.
Clean install now complete with appropriate WD stuff working.

What is a system image to Azure? How do you recover with that? How is that better than simply using Server Backup to a local USB drive?

Did you have firmware.zip in the c:\wd folder when you tried update from file in the gui?

Dear rbarbour02,
Thank you very much for posting how to install WD components (from fresh install)!

Dear Gramps,
In my case, I just installed the components from the downloaded directory, not from C:\WD. It all worked fine.

Dear Gramps,

I came across this thread and was wondering if you might shed some light on something? I have a client with the failed DS5100. The driver you referenced worked perfectly for me using a Hitachi / Travelstar as my new boot drive. Unfortunately for me, I went a step further after the O/S was installed and I tried to install a firmware update on the DS5100. This seemed to break the drivers (or something similar) and I am again unable to boot the server. After trying unsuccessfully to recover I decided to just reinstall the entire O/S. However now the marvell drivers are seen as incompatible and I cannot see the drive to install the O/S again.

I contacted support -its of course out of warranty and they cannot send me a boot drive. The tech repeatedly tells me that IF I purchased a Western Digital AV-25 drive it would be detected. I am suspicious and since I must order it online and it will take a week, my customer is getting impatient and wants to buy a new server if I cannot recover.

I would order the AV-25 if I thought it would work but I was wondering if you had any thoughts on his suggestion OR is there possibly another RAID driver that would allow detection of my drive?

Thank you for any input you can provide.

KR

Hum, I dunno
Sounds to me more like a bad firmware update.
can you just plug any other drive in to see it is seen?
BIOS is still set for raid did not get changed to sata or something

I may be wrong but I do not see how an av drive would be seen if others are not. If you have to get another server you could get the av drive anyway just to see. They are not that expensive and you could use it somewhere else to get your money out of it

Dear KR,

If I read correctly, you already tried loading the drivers as suggested in this thread, but the driver shows “incompatible” - that is, you were able to choose the Marvell driver file from the file explorer window, but the incompatibility error pops up - am I correct?

Hi!
I just wanted to share my experience with setting up my DS5100 from scratch…
So basically added an SSD (dont ask why) as main drive, and to install Windows Server 2012, i had to format my lovely USB key as UEFI… go figure, and add the system image in. O yes, I needed to add the Raid drives to detect the drive, the link is in this forum above :wink: (whared by Gramps https://www.dropbox.com/s/smy7xiaswjwxu1u/Marvell%20Raid.zip?dl=0 )
That got windows up and running but no WD DS5100 info…
So getting the firmware and drives was easy to download… now to install WTF!.. get them here: https://support.wdc.com/product.aspx?ID=1602&lang=en
The video fw is a double click and enjoy… now all the other drivers are…
Well until I got to this help I manage to move on :slight_smile:
So do go to windows server “turn windows features on or off” and activate .NET and CGI (this last one is the important one, at least it was for me) this gives access to the dashboard of WD.
now, also thanks to rbarbour02, unzil the firmware of all the drivers installed before, and copy the “Identity.xml” file in a fresh and newly created “C:\WD\Identity.xml” folder (and copied file)
We are almost there!
What I did, (and maybe there are other steps before this or after) is just to install (and only that one) the WSMonitor and the WDSoftawareUpdateProvider.exe
with this last one you can follow the release notes of the drivers (and installation instructions) -> go to dashboard, monitor, update, click on update from file, and choose the previous zip file.
As long as u did the identity.xml copy file and folder creation, you are good to go!!
Enjoy!

ok that was just not it… as I stated before I had changed the hard drive, so it was a non original or valid drive, and the stupid FAN was making me crazy!!
so I just followed this post Finding spare drive for DS6100
change the name (as stated in the monitor system) and voila! disk identified as preferred and temperature fan control working.
All set, ready to go!
Thanks all!