DNS-323 NAS SMB/CIFS Share Not Visible

Hi there,

I’ve been having really frustrating problems trying to get a consistent network share going using my DNS-323 NAS. Both the DNS-323 and the WD TV Live Hub are physically connected to the same router (a Linksys WRT400N).

I was having tons of problems trying to get the network share working a couple of days ago, and then magically it seemed to start working. Some combination of clearing login info, making sure my shared paths had no spaces, rebooting devices, etc. However, today, I found that all of my media was gone again.

The generaly problem is that the share doesn’t appear under SMB/CIFS. Just get “No Storage Present”. Both my DNS-323 and the TV Live Hub are perfectly accessible from multiple machines on the network (wirelessly), but the Live Hub can’t seem to see the share.

I tried installing an NFS plugin on the DNS-323 and go that route. The IP address appeared almost instantly when the share was setup, but then I got some “unknown error has occurred” when I actually tried to connect to it through the hub.

I’m getting really frustrated with the whole situation!  I’ve made sure to set the workgroup for all of the devices to “WORKGROUP”, and all of the other tricks I’ve read about, but I just can’t get consistent performance at all.

I’d really welcome any suggestions!


Hi. I have a similar setup and I have no access problem to the NAS. I suspect you are running the latest FW (3.00) and I would suggest you rollback to FW 2.07 and use this for a few days and see if you still have these issues. FW 3.00 is quite buggy and we all hope that the next FW update will solve those issues.

1 Like

Thanks TheCoolDude. You’re correct: I’m using the new firmware (3.00.28 I believe). I’ll revert the firmware and give it a shot! I’ll write another post to give an update on whether reverting solves the problem.

Wow – like night and day!

I downgraded to the version you recommended through the Knowledge Base on the WD site. I had some small troubles with the USB key being flakey, but after installing the new (old!) firmware, the share was immediately visible. Everything seems to be working just great! Thanks so much for the help. I was sure there was something I was doing wrong, but it appears it’s a firmware issue.

Thanks again! My music is finally working the way I wanted it to!

Glad I could be of help. To close this subject, mark you original post as “Solved”. Kudos are welcome as well. :wink: I had a feeling that you were running FW 3.00 as there has been many posts related to problems with networked/external drives. P.S you might want to post in the " http://community.wdc.com/t5/WD-TV-Live-Hub-Issue-Reporting/idb-p/Issues_LiveHub" tread to make it more visible to the MOD there.

Same problem but I cannot find the 2.07 firmware versione. can someone help with this?


sergio12 wrote:

Same problem but I cannot find the 2.07 firmware versione. can someone help with this?


Get your firmware from the page below and follow the instructions.


Thanks so much