Direct connect to pc not working

I have a brand new MyCloud Home. To troubleshoot an intermittent connectivity issue I want to directly connect via Ethernet to my pc. Using provided Ethernet cable white led never goes solid. I’ve tried several different plug/unplug/on/off sequences and white led just blinks slow.
No cloud found in File Explorer Networks tab on Windows 10 pc.
WD support says this should have worked so it must be broke :slight_smile: They offered an RMA and replace with a standard MyCloud.
I purchased a second mycloud Home tonight and same issue.
It works normally if connected to the router.

How do I direct connect to My Cloud Home via Ethernet?
I have searched this topic best I can and only find results for the MyClouds (not home)

really ? i would assume it wouldn’t work because the MCH (My Cloud Home) needs an IP Address to connect via Ethernet. Connecting it directly to a PC … the PC won’t give it and Address.

I understand you’re trying to troubleshoot …

I suppose if you have an Ethernet Switch laying around … that might work

eg. MCH connected to the Switch via Ethernet and then the Switch connected to the PC via Ethernet.

The Ethernet Switch should assign an IP Address to the MCH and then the PC will be able to access it.

WD my cloud home, requires active internet connection to access it.

White led blinking because it’s trying to connect to the internet. Use my cloud home connected directly to router with active internet connection

I see. Quite unacceptable. I believed that anything connected on the local network would still be accessible regardless of that the outside connection. Say Shentel a line cut or something. I was under the impression that a “traditional” NAS operated this way.
There are many instructions pertaining to the older MyCloud directly connected via Ethernet. And the WD tech was very baffled that it wasn’t working, he said they do it all the time…
Even connected through the switch I get nothing. Maybe it needs the router? But that the router doesn’t necessarily need outside connection?

One fear I have is that this functionality was removed from the MCHome.