Difficulty connecting to network with WD My cloud windows desktop app


So I’ve downloaded the windows desktop app to connect with my MyCloud however each time I attempt to connect either by activation code or by WDMyCloud.com login I get an error saying that there is no internet connection available.

I’ve tried this on a couple of different wifi networks and get the same error, whilst others who attempted to connect on their own devices have been successful in logging on.

I’ve had no issues in getting the android application to work on my phone using the same details which leads me to believe this may be laptop related (fyi: OS is Windows 8.1). I’ve disabled all firewalls in the hopes that it may help however it didn’t and so I’m out of ideas!

Any and all help would be much appreciated :slight_smile:

Welcome to the WD Community.

Have you tried using the application on a different computer?

Make sure that both devices are within the same workgroup.

We’ve successfully managed to get it to run on other computers with no issues and so I’m stumped!

As I’m using a different wifi network to connect to the my cloud back home, are there router settings I should be checking?


Just wanted to clarify a few things.

On the failure case or success case, were you on the same network as your NAS?

The “no internet connectionn” should only appear when you have no internet connection on your laptop or computer. So, when your laptop or computer isn’t connecting, can you still connect to another website?