The connection has timed out ? **bleep**

I have a My Cloud. when I log into the WD2Go page I can see the Cloud when I click the button I get a webpage stating: The connection has timed out! The Router and Modem are both working and connected to the net.

Trying to log in from work office also connected to net.

Is there a issue at WD on this?

Please help!! Thank


Have you tried using another browser or the WD Desktop App?

Yes I have been trying several browsers Firefox and Chrome. I can connect when I am on my home network but can not connect remotely.

I have tired the www.wd2gocom and the desktop app niether work remotely!

Ok so I am having the exact same problem. When I am in my home network I can access the device without any problems and it is quite fast. Whenever I am on an external network, it times out and I can’t access, using any form. Chrome, Firefox, the WDMycloud App for windows, either of Android Apps. WD Photos, or WD My Cloud. I’ve unplugged, rebooted the device and still no luck. I have the remote options correct since they’ve worked in the past including port forwarding. Any ideas?