Data transfer isn't fast enough

I’ve noticed that the download (and upload) speeds when transferring data from the My Cloud Home to my PC are lower than usual. I tried restarting the My Cloud Home and the PC too; nothing worked.
I reinstalled the WD Discovery app and the speeds were finally okay, however, after some time the speeds became slow again.

I believe the problem is the WD Discovery app itself. When downloading data from a different NAS in my network, the speeds are good enough.

1 Like

Best test is to compare “private user space” (via WD Discovery) and the public share (via SMB)…

Thanks for the tip.
I tested the transfer speed without WD discovery, and it was still the same - so it isn’t so slow because of the app.
After that, I changed the ethernet cable connecting the My Cloud Home to my router, but the speeds didn’t change. I also restarted it, but nothing has changed.

I always find my TimeMachine backup to go faster (and through).

I’ve been having the same issue. I believe it’s firmware related.