Connection Status - Connected (Relay connection established)

I am having problems with setting up new users (get error after I try to save the email), remote access not working and cannot create a code under cloud access.

I have tried to get support from WD either through calling or email since march 2014 having even changed Mycloud device twice, and the response from them are very limited.

Only recently I was able to speak to a high level engineer, and he was concerned about my connection status having a relay connection, so we tried to set the port on the Mycloud device and router Aztech DSL7000GRV to 8080 (Http) and 8443 (Https) and a static network. But the Connection status says unable to connect to port 8080 and 8443. He was unable to help me further, telling me he will call me again, but no one contacted me after that.

Can anyone help? Thanks alot.

Google indicates your router’s upnp is disabled by default. Revert the changes you had done earlier on both mycloud and router. Follow this guide to enable upnp on your router then reboot both mycloud and router. After both device up and running, point your browser to http://wdmycloud and see the cloud access status under settings tab.

Hi Nazar,

Thanks for the help! (which is so much faster than the WD support team). I did as per what you advised and the connection status is now Connected (Port forwarding connection established).

But both errors which i have been trying to solve are still there:

1. I am trying to create new logins and I got the following error:

The web access account you requested for could not be created. Ensure that you do not have any network connectivity issues and try again. (250006)

  1. Unable to save a enail for my 2nd User:

This email account cannot be deleted. Make sure your device is registered and your network connection is functioning properly, and then try again (250010).

  1. Unable to get code for cloud devices.

Any solutions? Thank you very much.


My NAS is intentionally down at the moment doing some major cabling managements. So I can’t really dig out what are those errors related to. But it seems you are unable to reach from your NAS from all those errors. Not sure about your router but is there any firewalls activated somehow?

Since your port forwarding is working now, I may advise you to reset the device once again using the 2nd reset option on the Dashboard settings which I can’t remember the name, system or factory reset. Its the same as the 40secs reset button as stated on the manual which clears everything except data. While waiting for the NAS to restore (about 20mins I think), go to your router and toggle the upnp off then on, or just restart. It will clear the current port forwards. You can also clear this via windows explorer->network. Your router will be visible there if supported and upnp is enabled. Find any wdmycloud alias and remove. I noticed sometimes the NAS will create duplicate alias with different ports which will cause port forward issue. This usually happens when the router is laggy to return current port forwarded list.

Tell you what, if this doesn’t work and since your port forward is working now, PM me, no promises but I’ll try to assist which you can post back the results here. I’m in the GMT+8 timezone. Me Zzz for now…


I do not have any software firewalls and I have checked the router, I did not enable the LAN side firewall.

Do I need to set up outgoing/incoming IP filters?

As per your advice, I did the system reset and restart the router and even set to default settings for the router and have resolved the number 3 point: Unable to get code for cloud devices, but I am still facing issues with the other 2 points.

I am also in the GMT+8 timezone.


Ok great, two issues down, two to go…

I’ve went through the codes. For the other two errors, the NAS was accessing API: api/2.1/rest/device_user. If you ssh into and check the logs, the specific error will be ‘DEVICE_USER_ALREADY_EXISTS’. The Dashboard error was not properly described, thus confusing to users and maybe to helpdesk too. Hopefully the fix is below.

I believe for your 1st and 2nd issues, there might be already a cloud device registered and active under each user. This is the reason you are not allowed to change the email (2nd issue) or signup to again with the same user (1st issue). If you need to save/change the email, or make a new signup which probably was deleted, first “remove all” cloud device in the Dashboard’s settings->cloud access->click on the user->cloud devices->trash. Then try change the email or signup again.

I managed to produce this error everytime. Anyway if it still doesn’t help, ssh into your device and let me see the last 100 lines of your log, type w/o quotes: “tail -n100 /var/log/user.log”…

>cloud access->click on the user->cloud devices->trash. Then try change the email or signup again.

After I click on the user, there is no cloud devices>trash,  instead I tried to go to the user tab> delete the 2nd user and created another user with a different email and i got this error:

The web access account you requested for could not be created. Ensure that you do not have any network connectivity issues and try again. (250007)

Note: User successfully added.

I am sorry but how do you ssh into the NAS. I enabled the SSH and download the program Winscp and tried to log in but it said Network error: Connection timed out.

That error 250007 is the same in this case. From the winscp, add a new sftp connection port 22. Also install putty which you can open shell terminal (ssh) from winscp. If you can’t connect to hostname, try ip instead.

Tell you what, temporarily port forward port 2222 on your router and forward to port 22 on the nas. Private msg me your wan ip (google what is my ip) and I’ll remote to your nas and debug. Remove any personal docs etc2 on nas prior letting me in…

1 Like

Hi Nas,

Thanks very much! I have PM you my IP address. Not sure if it is correct, I have put external port to 2222 and the internal port to 22.

Hi bro,

After all the hassle doing through the codes, my initial thoughts were right. Your NAS couldn’t reach the wd relay server. It can ping internet hostnames but can’t resolve the ips in applications including apache2 (wd dashboard) itself. It could be the router issue as I’ve checked that the /etc/resolv.conf points to the correct gateway which is your router’s ip. Also the reason I told you earlier that the router doesn’t respond to upnp request in timely manner.

I did a permanent fix to you NAS to update the host file. The host file will reset to default on every restart so I installed a cronjob to update it every time the NAS reboots. Note that this fix will be wiped out if you upgrade the firmware or perform a user/factory reset. So if you were to perform either of these, you’ll need to reapply this fix if you still encounter similar issue.

You may now remove the additional admin user (nazar) and port forward 2222->22 I’ve created on your NAS. Enjoy :smiley:…Zzzz


Thanks alot Naz! Appreciate your help!