Very Frustrated....can only establish a relay connection

have been reading all of the previous posts and have followed all the advice but no luck!  Can’t enable UPnP because I have another device that needs port forwarding and it appears that on my router I can’t have both active…  have forwarded 9080 external to 80 internal and 9443 external to 443 internal. Checked and both 9080 and 9443 are open…  My other device is using external 18443…  could this be the problem??? 

You have set up the port forwarding in the router. That’s good. Did you declare the setup in the NAS UI also?

Yes. In the UI I set it to manual and used 9080 & 9443 as the external ports. I also made the IP static.

Did you try to reboot your NAS. When I was doing this your way, I had to reboot to make the NAS switch to port forwarding. Eventually, I just relied on UPnP on the router, and I left Auto on the NAS UI. It worked better (no reboot), but it is a bit less convenient when you need to know which ports the router has opened.

I rebooted my NAS and it shows that it tried to use port forwarding… msg on screen: Connected (Relay connection established) 

 Port forwarding failed to connect on port 9080 and port 9443.

Any other suggestions???

See if this gets you anywhere:

No help there. Followed the steps to test connection on 9080 & 9443 and they got expected results …

I had a similar problem. In my d-Link router, I had to set up forwarding two rules. One for HTTP traffic and for HTTPS trafic. Once both were forwarded to the same IP, I could connect effortlessly from outside my home network.

Hope this helps.