Connect with samba with Mac OS X

Hi I have created new users on my MyCloud but I cannot connect them through SAMBA.
I would need to allow access to the shared folder directly from the operating system (Mac OS X through Finder)

By logging in with a browser, I can access the web browser.
On the other hand, when I try to access through the smb protocol directly from mac (finder) I get an error that says that it cannot connect.
For the connection I use the address: smb://192.168.1.321 (which is the IP assigned to My Cloud)
Once I select the desired folder (the user has read / write permissions) it gives me an error.
While if I try from my administrator account I can connect.

The user credentials are correct (from the browser I can log in) and the user has both read / write permissions on the folder (from the browser I can write to the folder).
The system is updated to the latest firmware version.

Could anyone help me?

Thanks so much!

This IP address is wrong. Last number must be less 255.

Yes, sorry the last number is: 123

Are you trying to give the users access to the Public folder?
You can share files in the Public folder without creating new users or new permissions - it is a guest account.
Have your users try to connect to smb://192.168.1.123/Public - that is the correct path to the Public folder. In Mac OSX, it would show up under /Volumes/Public if you select Go to folder in Finder.
If you created some other folder, I believe you have to include that in the path smb://192.168.1.123/NewFolder - I don’t think the MyCloud will let an ordinary user access to the top level folder.

Thank you.
I would like to avoid using public folders because I want access to certain folders only for certain users.
A public folder is viewable by all users with access to the connection, correct?

Correct - Public folder is for everyone on the network.
I think it is a permissions issue which is why admin can connect, but user cannot.
When you add a new user, Samba automatically creates a “home” folder for that user (under /shares/), so you have multiple user folders.
If you have not already, create the new shared folder (such as “NewFolder”) as admin, disable Public access (and Media serving), then give each of the users Full Access to NewFolder.
On a user’s Mac, ⌘K to Connect to Server in Finder then smb://192.168.1.123/NewFolder .

Hi @torch1
I create a new folder, I set as private and I shared with other user with read/write permission.
But if I try to access via smb://192.168.1.123/ or smb://192.168.1.123/new_folder I get the error.
What can be the problem?

Thanks so much!

Try connecting to smb://UserName@192.168.1.123/NewFolder in Finder.

Nothing, even in this way it does not connect.

Strange - it works for me. Are you sure you have the correct IP address? In Terminal on the Mac of a User can you ping it?
ping 192.168.1.123
If your network and MyCloud are set up correctly you should also be able to ping using just the MyCloud device name set in Settings > General > Device Name.
ping MyCloud
Not sure how much you want to learn about networks, but you could download Wireshark for your User Mac https://www.wireshark.org/#download and monitor your connection as you try to connect.

Login from your Admin Mac, then in Terminal type:
smbutil statshares -a
That will give you the status of your smb connection. Post the results or send me a private message.

Yes, I can ping the address.
PING 192.168.1.123 (192.168.1.123): 56 data bytes
64 bytes from 192.168.1.123: icmp_seq=0 ttl=64 time=102.088 ms
64 bytes from 192.168.1.123: icmp_seq=1 ttl=64 time=1.416 ms

I connect to the web interface by connecting to the browser with this address.

I can’t ping the device name.
I have this result:

ping WDMyCloudEX4
ping: cannot resolve WDMyCloudEX4: Unknown host

With the smbutil I have a empty result.

Thanks so much for your support

OK - something very weird with your network if it takes 102ms for the first ping to an IP address…
Have you set a device name for your MyCloud in the gui using the admin account? If not, you should. Settings > General > Device Name.
Also on your router, you should set a domain name for your LAN (do NOT use “local”); depending on your router, it is usually under the LAN > DHCP settings.
If you do both of those, you should reboot your router, wait a few mins, the reboot your MyCloud.
On any of your Macs and while connected to your local network, if you go to System Preferences > Network > Advanced > DNS:

  • DNS Servers - only the IP of your router (probably 192.168.1.1)
  • Search Domains - only the domain name set above

You should at least try from one of your User Macs to connect to the Public folder using smb://192.168.1.123/Public to see you have some access to MyCloud.

Yes, the Device Name is:
Schermata 2020-01-27 alle 20.51.01

In the network settings I see this:



If I try to access to the public folder i can connect.
I see all the files and folder in the public folder.
So
I think I can connect to public folders but not to private ones, although I have put read and write permissions for users…

Hmm…why do you have max SMB protocol set to SMB2? You should set it to SMB 3.02 (if that is an option) or leave it blank to let server & client negotiate highest protocol. Are all of the Macs on the same OSX version?
If you can see files in the Public folder using the smb:// connection in Finder then try the smbutil command while connected and post the results.
Also from Terminal:
dig 192.168.1.123
and
traceroute -v 192.168.1.123
These commands should show you how it is getting the route to your MyCloud…102ms sounds like it is going through an external DNS server (like google) rather than your router.
Ciao :slight_smile:

Thanks for your help @torch1
I’m trying also with the 10.14.6 and with the 10.13.6 version.

I try also with the admin user and the standard user with the same computer.
I have change the SMB protocol from SMB2 to SMB3.
But it still doesn’t work.

I did as you advised me, I connected to the Public folder and launched the two commands.

dig 192.168.1.123

; <<>> DiG 9.10.6 <<>> 192.168.1.123
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 3496
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;192.168.1.123.			IN	A

;; AUTHORITY SECTION:
.			10800	IN	SOA	a.root-servers.net. nstld.verisign-grs.com. 2020012701 1800 900 604800 86400

;; Query time: 2946 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Mon Jan 27 21:19:49 CET 2020
;; MSG SIZE  rcvd: 117

And:

traceroute -v 192.168.1.123
traceroute to 192.168.1.123 (192.168.1.123), 64 hops max, 52 byte packets
 1  192.168.1.123 (192.168.1.123) 60 bytes to 192.168.1.191  2.021 ms  1.245 ms  1.122 ms

Do you see something wrong? Thanks so much!

Yes - clients on your local network are going to an external Domain Name Server to look up a local IP address!!! This is how my dig response using device name “nas”:

; <<>> DiG 9.10.6 <<>> nas
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1897
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;nas. IN A

;; ANSWER SECTION:
nas. 0 IN A 192.168.111.240

;; Query time: 2 msec
;; SERVER: 192.168.111.1#53(192.168.111.1)
;; WHEN: Mon Jan 27 12:52:36 MST 2020
;; MSG SIZE rcvd: 48

Note the Query time difference - mine 2ms; yours 2946ms (almost 3 secs). Enough time for an espresso while waiting…
So your router is misconfigured…
Under your WAN settings on your router, see if there is one that says “Forward local domain queries to upstream DNS” - set that to No. You should not have to reboot after you apply that setting. Run the dig command again.

@issrl
Do you have an My Cloud EX4 as your screen capture above appears to indicate? If so note that the settings for the EX4 are different and may not be available on the single bay My Cloud models which are the general subject of this (My Cloud) subforum. If you haven’t done so already you may want to see and post in the dedicated My Cloud EX4 where users more familiar with that device may be able to assist.

https://community.wd.com/c/network-attached-storage/wd-my-cloud-ex4/108

Also note that some security/anti virus software on the computer itself may interfere with accessing local network devices such as the My Cloud devices. As a troubleshooting step disable that software and see if the issue persists.