Communications issues, error codes 30005 and 31505

I just purchased this 3TB My Book Live drive and installed it according to the insructions in the box.

The device works fast and fine as a mapped network drive. The browser interface is extremely slow. When trying to create a password, establish users, setting up shares, enabling remote access, etc. I get one of the following error messages and am unable to use the functionality:

30500 - Internal Server Error. Please retry your last operation.

31686 - Internal Server Error. Please retry your last operation.

31505 - The device status could not be updated due to an communication or internal software error.

30000 - Unknown error. Please ensure you are not facing network connectivity issues and try again. (rebuild_transcoding_500)

30005 - Unable to retrieve data. Make sure there are no network connectivity issues and try again.

31505 - The device status could not be updated due to an communication or internal software error.

and so on.

Basically I can only use the device as a drive. The MBL is connected to a megabit switch, which is connected to both my primary computer and my router. I am using Vista and Norton 360. Windows resident firewall is disabled, and N360 is providing security. Of course, the MBL is outside N360 coverage–hoping its own security is in place.

I contacted WD support, and their advice was to reset the factory settings. Before I undo several days worth of file copying, however, I’m wondering if there isn’t something else I could try, e.g., adjusting N360?

Network mode is DHCP

“Allow FTP” is selected


From all the errors you are getting, only the 30500 is referenced in the FAQ and may occur only when the drive has more than 95% of used space.  You may try disabling Norton 360 and check if there is a firewall enabled in your router that could be interfering with the access.  

Thanks for the effort…

I turned off my N360 firewall. Still got the error message(s).

Any way to re-load the resident NAS software without killing all the content? (The content on the drive now exceeds the space available on any of my computers, which is why I am hesitant to wipe the drive.)

Did you tried pressing the reset button on the back for 4 seconds? You can try that and it will not delete your files.

No luck.

I am having the same problem… just bought a brand new 3TB unit and installed it today.  Updated the firmware and having the exact same problems you reference above.  Did you ever get an answer?

I have another MyBookLive that works fine … no issues.  But this one is frustrating me.!

I’m another one with the same error messages. Exactly the same as the originator’s except mine is a 1TB My Book Live.

I’ve uploaded the firmware etc  but now I am stuck! I have the WD 2go app on the iphone ready to go!

Anyone with any ideas, please?

i have exactly teh same problem. i am usign MAC, no antiviruses, no firewalls on the router. the drive is 3TB MBL… help some one? did anyone get an answer?

Hi all,

after installing firmware apnc-021012-129-20120308.deb I have same problem. then everybody suggest me to restore factory default that causing loss data. but, I already “cut” my 1TB data and store to my MBL and it wasting my time if I re-backup my data to my computer. I searching and here what I do…

  1. going to remote my MBL via SSH. enable first by browsing this address http://mybooklive//UI/ssh

  2. under the command type /usr/local/sbin/ noreformat (save for the data inside MBL)

  3. then the browser can accessed normaly. but sometimes after setting the password for dashboard, the problem comeback.

  4. upgrade the firmware to apnc-021109-053-20120413.deb and the problem gone.

hope this helpful

I have just purchased a 2tb mybook, and whilst working through the configuration, I get the same errors. I have emailed WD support so waiting for a response. I have yet to copy any data on the drive yet so there is no chance that it is full, which also means a reset just means a loss of a few hours getting this far. Anyone had a official fix on this yet?

Hello All,

After spending 2 days trying to fix my new WD Mybook Live 2TB box and reading many help forums, I eventually phoned the EU support line to ask them where I can tactfully shove this piece of equipment where the sun doesnt shine… once calmed down we went through further diagnostics including resetting to factory settings.

After that didnt work, it was reported as faulty - so im now having to order a replacement from Amazon.

P.s it just took me 10 minutes to sign up to this forum just to update you all. I get the image passwords but why make them so ridiculous hard to read!?! Computers cant read image text so just make it clear and easy?

I’ll reply with updates if my new replacement works.

Hello westbounduk, I’m having the same problem. If it works for you than I’ll get the same thing done. Keep us in the loop.

Hello harmadiwibowo, Can explain item 2? Under what command type did you use? Did you mean the command prompt under windows?

Well I did a full factory reset and that has resolved my errors. So now I can start using the drive. I did also get an email response from WD, suggesting a full reset, and if that failed to arrange a RMA so I could receive a replacement. Thankfully don’t need to that now.

So if anyone else is having similar errors, you going to have to bite the bullet and do a full reset. Not very good if you have to spend hours backing-up your back-up.