Clean OS (Debian), OpenMediaVault and other "firmwares"


#1579

Check /sys/class/leds - if something pressed, then control is possible.


#1580

Hi

@Fox_exe Thank You for your answer.
Sadly, there is no such parameters in this directory. It’s no big deal, it was juste a comestic tweak :slight_smile:


#1581

The gen1 has /sys/class/leds folder. The gen2 uses the /tmp folder. If you checkout
the ledCtrl.sh ledConfig.sh file in /usr/local/sbin You will see how they control the color of the led.


#1582

I found nothing useful (as far as I can understand btw).
Thank you very much for your help.


#1583

It appears that the Gen2 uses a different method to control the leds. Even though the ledConfig.sh and ledCtrl.sh ar present they don’t seem to be used.

I think the Gen2 uses a program called set_pwm to handle the leds and the disk standby Among other things.


#1584

With Synology DSM can we install Home Assistant? Thanks.


#1585

Any progress with led control ?
I really would like to modify the second and third led to turn off if the my cloud and its disks go into sleep mode


#1586

Hi,
i’m not sure if i got the howto right. I have a WDMyCloud-Gen2 with 6Tb and would like to install Debian with OMV on it.

The first part of the howto:

======= FW SETUP =======
Copy uImage, uRamdisk and rootfs-jessie.tar.xz to /boot/boot (Overwrite all)
Reboot
Connect via telnet
Repart HDD (Skip 3rd partition):
parted /dev/sda
rm 1
rm 2
rm 4
rm 5
rm 6
rm 7
mkpart primary 0% 1G
q
mkfs.ext4 /dev/sda1

Bevor doing that i tried if ssh and telnet to see if it works. I can ssh to it, but telnet does not work, i only get an “connection refuesed”.
I can’t figure out how to get telent to work on it.

Can somebody help me out please.


#1587

If you have ssh, you dont need telnet. Telnet is depreciated. ssh is the preferred means to remote administer. More than likely telnetd is not running, which is why the connection is refused. Since telnet does not use any kind of encryption to prevent eavesdropping on your administration session, it is highly discouraged to use it. SSH is the preferred means.


#1588

@Wierd_w, Telnet used in my Ramdisk because its lighter thas SSH (Dropbear) and easy for configure.
And… Its used only for restore device. Only if ramdisk can’t start primary OS.


#1589

@fox_exe, Nice to know. I did the partitioning and data transfers outside of the mycloud when I set mine up. For me, I had SSH right away. I just needed to know what partitions where what, and off I went. I made the system partition a little bigger than your instructions. (Once you start installing packages, those dependencies can get pretty hungry for disk space.)

I was more meaning to the prior poster, that if you have ssh (which he says he does), then he does not need to worry about not having telnet, since telnet just gives you a remote console, which ssh provides, and provides better.


#1590

OK, Telnet only works in the first step of installing Debian, not bevor or after!

Big THX @ Fox_exe for his work :+1:

I installed Debian and OMV, and after little hiccups it worked (had a typo while installing Debian, mounted sda3 on root wrong, and at the end had to unmount sda2 via ssh so i could create a share in openmediavault).
Did a rebeoot, tested one share with samba and ftp and all went fine.

After i was finished, i chose the option in OMV to shutdown, and afterwards pulled the plug. A few hours later i wanted to boot my WDMyCloud-Gen2 up, but i can’t connect to it.

I can ping it, and it is there, but no webgui, no SSH (connection refused), no FTP or Sambashares.
After booting up the LED stays white (or yellowish)

I have no idea what is wrong, or what did i do wrong?
Any sugestions?


#1591

I tried the unbricking manual;

extracted usbrecovery.tar.gz on two different USB sticks formated to fat32, it is a boot folder with 4 files in it (uImage, uImage-wdrecovery, uRamdisk and uRamdisk-wdrecovery)

When i switch the myCloud-gen2 on, i have fast blinking blue light, and after that it is constantly white or yellow.

ping: works
IP: OK
telnet: Unable to connect to remote host: Connection refused


#1592

Pulled the plug
Put the USB stick in the back
Pressed the reset-button on the backside for 40 seconds
switched it on again

It works again!!!

Wanted to see what happens after i reboot it again; white lite, no ping, no telnet, no ssh, no service, no nothing :frowning:


#1593

Well,
i left the device on (to see if giving it time would help) and went to sleep.

In the morning the device was still on, but no SSH oder samba reachable.

I pulled the power, and restarted it again. After a short time i got a green LED, pinged it, samba works, ssh works.
I have no clou why or why not.

What is (usualy) the safe way to shutdown or reboot OMV with clean Debian on it?


#1594

ssh into the box, and run

shutdown now

#1595

Sleep and WOL not supported, so device after “Poweroff” command just stop OS, but not drivers. Networks still active, but system is “hung”.
Need manually reset power after shutdown.

Also do this: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Debian/Dev/_Update_Kernel_and_os_EN.txt


#1596

so if i shutdown throgh ssh, system will not hang on next boot?


#1597

Fox_exe
the purpose of that manual/fix is to make sleep and WOL work?


#1598

I am also trying to connect my USB-Stick to it, so i could copy files faster than trough smb.
I can’t mount the USB device because Debian does not seem to register it (blkd or fdisk -l only show the internal HD)