Clean OS (Debian), OpenMediaVault and other "firmwares"


#1559

I followed this guide: https://www.akadia.com/services/ssh_test_certificate.html

Following that I was able to create one, though still need to figure out how it works and I havent managed to run/install Nextcloud yet so don’t know how it will work.

I’ll take what you gave me to make another certificate for 10 years. Dude, thanks for real!


#1560

When I remove the hard drive from my WD MyCloud Gen 1 (3 TB) can I just plug it into a Mac or Linux Computer and access the files? The restore process via DHCP, TFTP and PING doesn’t seem to work this time.

Although this is the third time I am restoring the device this time the DHCP requests don’t show up. The LED stays yellow and I can’t connect.


#1561

Well, you can read/write the drive using your favorite linux distribution since it’s standard ext4 file system.


#1562

Hey @Fox_exe, I am looking to build a custom kernel for my gen2 using more recent kernel sources (I see you have 4.xx kernels available, so I would like to build one myself using that tree) that has zram enabled and a few other bits and bobs.

You dont really have good instructions for this. Any tips?

I ordered an EX2-Ultra, which I will put in service as the NAS, and that leaves the gen2 free to turn into a dedicated small debian box. I intend to put an SSD inside it, so I dont want to use a swap partition, hence the zram requirement.

Failing that, could you just build one with zram baked in?


#1563

https://fox-exe.ru/WDMyCloud/Other/Official_linux_kernel/


#1564

Thanks Fox!

I will dig into it in a bit.


#1565

Hello
I write for the first time on this forum.
Can you imagine my joy when I learned that DSM was available for my old MyCloud taking dust?

I tried the first recommended method to install DSM, but the Mycloud got bricked.
So I took the MyCloud apart, and plugged the hard drive directly into my *nix.

Now I’m stuck at this stage:

Connect to WDMC via Telnet and run this commands:

parted /dev/sda
rm 1
rm 2
rm 3
rm 4
rm 5
rm 6
rm 7
rm 8
mkpart primary 0% 2048M
mkpart primary 2048M 3072M
mkpart primary 4828M 100%
mkpart primary 3072M 4624M
mkpart primary 4624M 4724M
mkpart primary 4724M 4824M
mkpart primary 4824M 4826M
mkpart primary 4826M 4828M
q

source : http://anionix.ddns.net/WDMyCloud/WDMyCloud-Gen1/Synology_DSM/_howto_install_en.txt

Parted gives me an error related to misaligned partitions.

I can’t solve these problems, and if I ignore them, then problems arise when creating file systems.

I’m asking for a little help to get me out of this mess.

In any case, a huge thank you to Fox for all the work done and for the documentation produced.


#1566

Hello
I’m not giving up on this.
I tried to create the partitions with the windows tool. The partitions were created in the right order, with larger sizes than those given (cropping on the sdb3 part).
When plugging the hard disk back into my *nix, parted and fdisk find no errors.
The commands indicated in the operating instructions run correctly without any errors.
After reconnecting the hard disk to the MyCloud board, the system does not start (the LED remains red).
I think my mistake comes from the fact that I did not apply the following DSM installation instructions:

=== BOOT TO RECOVERY ===

  1. Change computer IP adress to 192.168.0.1 (Mask: 255.255.255.0, gateway and dns - empty)
  2. Change MAC address in _Start_Ping.bat
  3. Run _Start_DHCP.bat and _Start_TFTP.bat
  4. Power ON WDMC
  5. Run _Start_ping.bat (And run again and again until its start ping WDMC)
  • In DHCP window you can see something like this:
    DHCPREQUEST for 00:90:12:34:56:78 () from interface 192.168.0.1 received
    Host 00:90:12:34:56:78 (Host009012345678) allotted 192.168.0.2 for 36000 seconds

    DHCPDISCOVER for 00:90:12:34:56:78 () from interface 192.168.0.1 received
    Host 00:90:12:34:56:78 (Host009012345678) offered 192.168.0.2

  • And inside tftp window:
    Client 192.168.0.2:1025 data\startup.sh, 1 Blocks Served
    Client 192.168.0.2:1026 data\bootimage, 11574 Blocks Served

  1. Wait few seconds. You can close _Start_ping window. No need it anymore.
  2. When you see Green light - all done

Would it be possible for someone to enlighten me on the steps to follow on these last / first steps.

I have no idea where I should put these files :
data\startup.sh
data\bootimage

Thank you!


#1567

I’m starting to think I need an operation like this:

dd if:/startup.sh of:/dev/sdb conv=notrunc
dd if:/bootimage of:/dev/sdb conv=notrunc

But I don’t know what additional argument to pass to get a writing of these files on block 1025 and 1026 as in the instructions given by Fox, for the record :

Client 192.168.0.2:1025 data\startup.sh, 1 Blocks Served
Client 192.168.0.2:1026 data\bootimage, 11574 Blocks Served

I hope someone will give me an answer :slight_smile:


#1568

tftp is trivial file transfer protocol.

dd is disk dump.

they are not the same thing.
Check inside _Start_TFTP.bat

The remote location where the files are to be copied should be present there. raw writing on the disk with dd is a great way to totally hose up the file system on that disk. Dont do it.


#1569

Hello

Thanks for the answer.

The fact is that for the moment, DSM does not boot with the installation of all other files provided by Fox.

So I have to add the boot files, right ? What else could prevent the system from booting ?

_start_tftp.bat just runs OpenTFTPServerMT.exe without arguments.

The .ini of OpenTFTPserver is such that :

[LISTEN-ON]
0.0.0.0

[HOME]
tftproot

[LOGGING]
All

[ALLOWED-CLIENTS]
192.168.0.1-192.168.0.255

[TFTP-OPTIONS]
port-range=30000-30999
ThreadPoolSize=20
timeout=10
blksize=65536
read=Y
write=y
overwrite=y

No destination folder is specified. The source folder is the tftproot folder which contains at its root the files RECOVERY and STARTUP.sh

I’m a bit lost…

All of this started with parted being unable to create the needed partitions without misaligned errors :weary:


#1570

Okay…

I followed all Fox instructions one more time, but using gparted instead of parted (because the gparted interface allows you to choose alignment when creating a partition), and everything works perfectly, whether installaing dsm or reinstalling MyCloud (I had another unused hard drive, so I made a MyCloud install & a DSM install).

This was so simple.

Thank you so much for the instructions! :smiley:


#1571

Hey @Fox_exe, I have it “working” with home built 4.14.4 but for some reason the network interface gets renamed to eth2, and does not go up on its own. I had to abuse rc.local to make it come up with a static address so I could talk to it. (Took me having to output dmesg and ifconfig -a outputs to a file on the home volume then removing power to the unit to figure out that I needed to manually up the interface, and that it got renamed)

Also, despite it connecting and going up, the link light on the port does not light up. It seems to work otherwise though. The link light is a just a trivial annoyance, but I do like to know when my cable is bad. :stuck_out_tongue: I am more concerned about how it does not automatically up the interface, and it renames it into something strange.


#1572

@Wierd_w, delete old udev rules:
rm /etc/udev/rules.d/70-persistent-net.rules and reboot device.


#1573

Dear all,

I have EX2 Ultra nas with stock firmware and already filled disks with my data.

I only want to install DSM to have GUI like Synology - and I don’t want to loose my data from NAS disks.

Is it possible to only install DSM without loosing data on ex2 ultra nas?

Thank You!


#1574

The EX2 uses a cramfs container, like the Gen2 does. (I now own one of each!)

Since the cramfs container is where the GUI code lives, switching out the GUI will not be an easy task. So, unless you want to go very custom firmware, the answer is a tentative “no.”


#1575

Thank You for answer.

So should I install DSM+Debian on my ex2 ultra? Will it be possible w/o losing data?


#1576

Hi Fox_exe,

I’m sorry if my question is noob. I got a WD My Cloud Gen 1 4TB which was bricked after I tinkered a bit with installing Clean Debian. I’m planning to save my files there to another drive and then clean install DSM. Should I restore it to original FW then from there install DSM? Is there a way to go straight from a clean HDD to DSM?

Thanks a lot.


#1577

@wesker571, DSM and Debian is different OS (don’t depend from each other).
You can install one of them, not both.
Another solution - Debian + OMV (OpenMediaVault - just a “web-gui + software”, not a dedicated OS (or firmware))

Note: While install DSM disks will be formatted. All data is loosed.
In theory - its possible to save all data - just prepare disks in “DSM” format… But i not test this method, so can’t provide any help for this.


#1578

Good evening.
Everything works very well on my DSM, again a huge thank you!
Just a little aesthetic question: is it possible to change the color of the led? (by default, it is lit in orange, I would prefer white, or blue if necessary).
Thank you!