Changed name, now can't connect

Hello. Please help.
I just set up my My Cloud mirror and I changed the name of the device in the settings. I can now not connect to http://www.wdmycloudmirror.local/
I did both a reset while the power was on and also powered it off to reset. Neither of those things worked.
Anyone have advice? Thank you.

Try replacing wdmycloudmirror with whatever name you gave the device.

Alternatively look up on your routers dashboard what IP address the MCM has now and use that instead.

Thank you,DarrenHill! It sort of worked, now I get a page that says WD MyCloud Mirror in the upper right hang corner, but no dashboard. Suggestions?

So that’s the login page, but without the login box in the middle?

If you’re running any kind of noscript plugin, ad blocking software or anything like that in your browser then disable it temporarily and see if the login box appears on that page. Also if you have JavaScript disabled or anything like that also enable it temporarily for the test.