Can't Wake Up Device Through WiFi

Hello: When I’m remote and My Cloud Personal Storage is asleep, I can’t wake it up. If I have someone unplug and then plug it in, it will connect through WiFi. How can I wake it up remotely if it is asleep and there is nobody to cycle the power?

Here’s what I get when it is asleep:

Go to: Mycloud

Click “Sign into My Cloud” button

Enter name and password and click “Sign In”

It says “Signing In”

Then waits for about 30 Seconds

The I get this message:

Can’t connect to WDMyCloud. Here’s what you can do to try to fix the problem.

I click “Accept your device’s security certificate”

Then I get a new screen with a “Continue” button which I click.

Then I get this message:

This site can’t be reached

Device (My device number shows here.com) took too long to respond.

Try:

  • Checking the connection
  • [Checking the proxy and the firewall]
  • [Running Windows Network Diagnostics](javascript:diagnoseErrors())

ERR_CONNECTION_TIMED_OUT

Then I get two buttons: Reload and Details. Neither of them works.

When the device is awake, I get an option to proceed anyway. But not when it is asleep.

Thanks

@richlocus Which WD Device do you own that has wifi?

The WD MY CLOUD does not have wifi. WDMyCloudImage

Hello:
MyCloud doesn’t have WiFi. It is connected via Ethernet cable to a Comcase Router. When I’m remote, I use WiFi (i.e. Starbucks) to connect over the Internet to my Router. It, in turn, uses an Ethernet cable to talk to my MyCloud.

Hope that makes sense.

Rich

@richlocus Yes, I have two WD My Clouds that work the same way. I do own my modem and Linksys router.

Do you have everything set up in the Dashboard for Cloud Access? See example image below of mine.

In Settings>General

image

Thanks for the hints! If I power cycle the device, then I can use the remote connection, so I know I have the proper setup. But if the device goes to sleep, I can’t connect.
Regards,

Rich Locus

Have you tried turning off Drive Sleep when you are going away and want to be able to reach it?

Hello cat0w:
Turning off drive sleep is my next experiment. The only issue is that I don’t want to leave it in that state because I’m assuming the drive still spins and slowly wears out the bearings.

I could not find where I could set the timeout period for sleep… such as “don’t go to sleep before two hours of inactivity.”

Rich

On the gen1 the sleep time is in the file /etc/standby.conf. Not sure where it is on the Gen2.

Not sure how to get to the file path you indicated. Looks like Unix. I’m in Windows.