Can't connect to WDMyCloud

whenever i try to access my device through the web it says Can’t connect to WDMyCloud. and am sure that my device is connected to the internet.

Same thing happened to me through trying to access

I had to access the user interface locally and disable my admin password, then reapply it.

delete your cache on your browser then try it again.

Hope this works for you!

1 Like

Try turning off remote access in the Dashboard Settings menu waiting a few minutes, then turn it back on. Sometimes that fixes problems with remote access. And as the previous poster indicated sometimes reapplying the User’s password, or disabling then reenabling remote access for that user.


I tried to remove the device from the interface and add it again… it works fine now… thank you both for your reply i really appreciate it.


I’m new to MyCloud and have been having similar connection issues to the ones described here.

I have tried the “turn off remote settings (now called “Cloud Service”?)” method mentioned above and it worked fine.

The problem I have is that I tend to switch the WiFi and MyCloud off at night, hen I switch it back on in the morning I cannot connect remotely until I have switched off cloud service and switched in on again. Should I have to do this every time I want remote access?

Once I have re-started the cloud service I can connect remotely with no issues, Its very irritating.

Has anyone had similar problems and found a good solution?

Thank you in advance for your help


You probably shouldn’t have to…

On the other hand, you probably shouldn’t turn the power off every night, especially if you don’t shut it down properly first. It’s intended to be always on, and you are gambling with data corruption if you just turn the power off.

+1, mycloud is design to be 24x7. Annual expense for electricity is minimal.
If you have to turn it off, do NOT just just unplug the power cable. Do it via the dashboard (check manual) or CLI (search posts, plenty of this subject).

my cloud showing on the network but not showing on mycloud/setup, what should I do?

This restart of remote access under settings worked for me. Don’t know why I had to sift so far to find this solution. Restarting the WD Cloud device should have fixed it, but no! Also, replaced my router, prior, to no avail.