Can't connect to wdmycloud

Get the above message when I try to sign in.
Can access the device via ip address and can see that software is up to date.
At the moment am transferring file from pc to mycloud via wifi
Any help wpold be appreciated

More information is needed. What program or software are you using when you receive that message? What are you trying to access when you receive that message? The My Cloud Dashboard? What operating system are you using?

Thanks for replying
I’m using Firefox browser running in Kubuntu.
The URL is:- https://files.mycloud.com/index.php#23a3c71/device_27343755/Public/
This usually connects to wdmycloud sign-in but after providing the usual user ID and password I get the message shown above.

Are you trying to access the My Cloud on the local network or a remote network? The MyCloud.com web portal is for remote access when not connected to the same local network as the My Cloud. For local access on the local network one can use a file manager program to access the user files or one can use a web browser to access the Dashboard.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13965

I’m trying to access via the internet. I can access mycloud locally on my wifi but the MyCloud.com web portal has features not available locally. It has been working for me for some time but suddenly presents the arror show above.

Sometimes one has to cycle the Cloud Access > Remote Access option under Dashboard > Settings to fix certain remote access issues. Sometimes if the local network router the My Cloud is connected to is rebooted the My Cloud may loose remote access until the Cloud Access option is cycled off then on.

1 Like

Ah yes! I see that the device had a failure yesterday. “Network Link Down” and “Power loss detected” were notified.
I’ll try the access recycling thing.
Thanks

Yes, after some time it started working again
Thanks

I had exactly the same problem after a fairly long period of time when remote access to my WD My Cloud device had worked without any problems. And yes, going into Settings, switching Cloud Access off and then switching it back on again did the trick - my remote access is now back up and running again. Thank you so much for that solution!

“Have you tried turning it off and on again?” :upside_down_face: