Can't uninstall Wd My Cloud error code 2318

Can’t uninstall Wd My Cloud error code 2318 how to uninstall so I can reinstall with the new firmware

What are you attempting to uninstall?

One doesn’t uninstall the firmware on the My Cloud rather they update the firmware. If you are having trouble updating the firmware automatically within the Dashboard one can download the firmware and manually update from within the Dashboard. Download the latest firmware at the following link:

The following WD Support Document explains how to update the My Cloud firmware.

I have already tried to do a manual update of the Firm ware and received the same failure message, stated to contact WD .

So I thought after I tried a pc reboot to be sure all software had loaded properly I would try again and got same error. Then I thought I would try to uninstall the My Cloud

desktop app and got a error saying couldn’t be uninstalled error code 2318. I figure this is why I can’t update this app.

Firmware What model of My Cloud do you have? Where are you getting that “Firm ware” value from?

The single bay My Clouds have never had firmware that was below 3.x for the first generation or 2.x for the second generation units.

Again, what are you trying to uninstall? The WD My Cloud software from the computer? If so what specific software are you uninstalling? The WD My Cloud Desktop program?

To update the firmware on the WD My Cloud one can use their web browser to access the WD My Cloud Dashboard. See the following WD Support Document for more information on how to access the Dashboard.

Once you have accessed the Dashboard, refer to the “How to update the firmware on a My Cloud device” document link I posted above to perform the actual upgrade through the Dashboard web browser user interface.

I don’t think you and I are on the same page I got a automatic up date from WD for My Cloud desktop app. That’s what wont install and that’s where I got the software version number from.

I have taken a snap shot of it and attached for you to see Capture 2 is the message I receive when trying to install . As I stated before I thought if I could delete original software and do a fresh install it would take

but for some reason I am unable to remove the My Cloud desktop app. I have a 3 tb My cloud Model WBCTL003HWT-00.

@Grover_Bates, no we were not on the same page as it wasn’t clear what exactly you were talking about, the WD My Cloud device or the WD My Cloud software. The term “firmware” specifically refers to the WD My Cloud device NOT the WD My Cloud software one installs to their local computer.

What operating system are you using? Have you tried downloading the latest version of the WD My Cloud software that you are trying to update on your local computer from the WD Support site? See the following link:

I am using windows 10 and all software is up to date I have found a old post with the same problem and it says to down load a fix it tool from windows support to be able to remove software then install but so far I haven’t found the tool will keep looking. Well I think I will leave well enough as is because everything is working just can’t update software or uninstall it to load new version. Note as near as I can tell there is no fix it tool for windows 10 and all software removal tools are a fee based tool which I don’t need for one software as it works just can’t update it to newer version.

Hi There Grover,

I had the same problem. same error. I think something happened while updating my virus scanner en it give a notification about two possible infections so I clicked remove. After that I wanted to update My WD Cloud desktop software so it started downloading the software. When I tried to install the new version it gave me the same error as you described.

I tried to uninstall the application but that gave me also the error. At that point I just was thinking. I don’t want to spend anymore time on this. So I just deleted all registry entries manually. Be careful when you are going this way because it can destroy you OS :P. You can access it by typing regedit in the search field under start.

So I deleted all the entries with Western Digital, I found a directory in my roaming folder tried to delete everything, almost everything was deleted. After that I went back to the application manager to see if the WD My Cloud Desktop application was still there! Now I was like, it is still here! So I just tried to uninstall again and now magic happened for me :). No error popup this time it just uninstalled the application. After that I freshly installed the new application and everything was working smooth again.

Hope this was helpful for you, cheers :).