Can't re-map Network drive in Win 10 File Explorer

I have a 6TB NAS My Cloud I got about 6-7 months ago as part of the OS3 phase out program. I was able to connect to it using My Cloud Home as well as mapping it as a network drive on my LAN in Win 10 (easier for me to transfer files). It has been performing very well in both of those modes for the last 6 months. I also have an older 6TB NAS My Cloud that I believe is still running OS3. It also has been performing well in both modes.
I recently added a 12TB DAS drive for supplemental backups. That showed up right away in Win 10 File Explorer. No problem.
While routing cables & power supplies under my desk with pc system powered down I had to briefly cycle power to the newer NAS.
After bringing system back online the previously mapped newer NAS drive had disappeared from file explorer. The older 6TB NAS was still visible and accessible. The newer NAS device does appear under Network group under the MyCloud+S/N format name but this won’t show all my files, only the unused “Public” folder.
Nothing I’ve tried will restore the mapped drive in File Explorer. The drive is visible in router setup with correct IP address & MAC # . I can view all my files using the My Cloud Home app from my desktop, tablet & phone but it appears totally invisible for File Explorer mapping purposes. I have tried searching for it using IP address, drive name, network name etc. but can’t get to it by the mapping path.
Can’t figure out why after 6 months it threw this tantrum but it is very frustrating to say the least.
All system drivers appear to be up to date.
???
Help

If you are having a problem with a My Cloud Home device, see the dedicated subforum for that device where users more familiar with it may be able to assist with your issue.

My Cloud Home
https://community.wd.com/c/home-cloud-storage/my-cloud-home/229

The My Cloud Home is completely different than the My Cloud line of devices (that this OS5 subforum discusses). The My Cloud Home does not use OS5. The My Cloud Home has different options and features than the My Cloud line has.

My Cloud, My Cloud Home, & My Passport Wireless: Not Detected on Windows 10 & 11 Network
https://support-en.wd.com/app/answers/detail/a_id/3842

My Cloud Home: Private User Space & Public Share Access
https://support-en.wd.com/app/answers/detail/a_id/3009

The following may or may not apply to the My Cloud Home:

How To Map a WD Network Drive on Windows 10 and 11
https://support-en.wd.com/app/answers/detail/a_id/25436

Update:
I opened WD Discovery app (as I had already done a couple of days before) and after logging in to my 6TB NAS drive through the link there, the drive spontaneously reappeared in my File Explorer with full files & original name & assigned drive letter.
This may be how it resolved 6 months ago when I first set up the drive but since there didn’t seem to be any correlation to any significant action on my part at the time I didn’t link the solution to anything specific. I’m happy it resolved but would be happier if there was a specific course of action that I could use in the future. :face_with_spiral_eyes:
Also apologies if this question was posted under the wrong topic. It seemed like the closest I could find.
Thanks all.