Can't map MyCloud PR4100


I’ve been using this NAS for the past 4 years. I generally use it as an external drive attached to my network and store data. After a glitch in my Laptop, I had to reinstall windows 10 and I got the newest release 1909. I added my cloud to the network but when I tried to map the drive so I can add to the windows explorer I’ve had problems. Namely, I can’t get “MAP” over the NAS folder in Network and I can’t access My cloud through the address bar as well. I tried writing the name of the device and the IP address, but either way, it automatically transfers to the Dashboard. I spent days on the internet reading for options. I even turned on SMB protocols. Any other idea as this is becoming quite frustrating for me.

My suggestion is that you post in the proper NAS sub-forum. See image below. Newest Version of Windows 10 is 2004. See second image.



Thank you for pointing that out. I changed the sub-forum.

I see you have a Home eddition. Does that changes regarding the newest release as I use Pro. I went to Updates, but is days that there are no updates. How do I update to the lates version? Will anyone else join this thread to help me or you can give me a hint? Sorry for the basic Qs, but I am just an average skilled user.

I actually figure it out my self. It is funny that no one on the internet is not mentioning that I shoiuld use a “backslash” in windows explorer so I can map my NAS. Ridiculous. Not even mentioned in the WD manual. So unprofessional