Can't log in to My Cloud using a secure connection

Yesterday, I upgraded my My Cloud from OS3 to OS5. However, I cannot access the dashboard on my Windows 10 PC using https. I can only log in using an insecure connection.

I am receiving an error …

Firefox does not trust this site because it uses a certificate that is not valid…


Unable to communicate securely with peer: requested domain name does not match the server’s certificate.
HTTP Strict Transport Security: false
HTTP Public Key Pinning: false

I would add that my drive is still only 15% indexed after 24 hours and that I use a static IP which I set up on OS3 so I could use a SSH app on my phone to turn the drive off in the case of a thunderstorm if my PC wasn’t on.

Can anyone suggest what might be the cause of not being able to log in using a secure connection please.

See the following WD Knowledge Base article where there are a number of articles that indicate issues with using HTTPS. Perhaps one of those articles has the solution or workaround to your issue.

My Cloud OS 5: Online User Guide and Solutions

Specifically the following:
My Cloud OS 5 HTTPS Redirects
30002 My Cloud OS 5: Unable To Connect Using HTTPS://UNIQUE_DOMAINNAME
29832 My Cloud OS 5: Dashboard URL Redirects to HTTPS Device Unique Domain Name
29834 My Cloud OS 5: Dashboard URL Doesn’t Redirect to HTTPS Device Unique Domain Name
29835 My Cloud OS 5: Dashboard access to a My Cloud Device showing “This site can’t be reached” message when using HTTPS

I read most of those links beforehand. I tried a few things but I’m not technical so some of this is way above my head.

However, that MXToolbox site mentions the folllowing so maybe this is the problem. I’ve blanked out my actual IP Address. This is my ISP’s IP Address not the NAS drive’s IP Address on my network. I have no idea what I can do about it if this is the issue.

You are on 1 blacklist: [Spamhaus ZEN](Spamhaus ZEN - BLACKLIST IP ADDRESS)


When I click on the link to open my My Cloud I get what is in the image below and must sign in.

Click on, tap, or activate image to enlarge it.

After I sign in, I get this.


I only see this if I stay on http://. It won’t redirect to the unique URL.

I forgot to add that my default browser is Microsoft Edge. Are you using Firefox as your default?

If you have followed the directions of pasting in, for example, into and it doesn’t indicate a result of DNS record found then you likely have a network configuration error of some sort (with DNS or similar settings) that is preventing the WD domain names suggested in the My Cloud OS 5: Dashboard URL Doesn’t Redirect to HTTPS Device Unique Domain Name article from resolving properly. One suggestion that article makes is the following (use Google DNS servers):

Google Public DNS Server

  • For My Cloud. please refer to Answer ID 17215 How to Use Google public DNS servers on a My Cloud
  • For Routers, please contact your Network Administrator, IT Department or consult the routers user manual or technical support department for assistance. Western Digital Technical Support does not provide 3rd party router configuration assistance.


I tried the Google thing but it made no difference. The other information on that page is over my head.

When I put the redirect URL in MXToolbox I get the following (see image).

@cat0w - the same problem persists whether I use Firefox, Chrome or Edge. This is Edge.

What happens when you click the Continue to wdmycloud (unsafe) link?

Does the same happen when using the My Cloud IP address rather than the My Cloud name when trying to access the My Cloud Dashboard?
Does the same happen if you use https://wdmycloud.local when trying to access the My Cloud Dashboard?

My Cloud OS 5: How To Access the AdminUI Dashboard

Not Secure or Certification Error When Accessing a My Cloud Dashboard Can’t Connect To My Cloud Accept Device Security Certificate


If I click ‘Continue to wdmycloud (unsafe)’ it takes me to the insecure login.

The problem is the same if I log in with the IP address.

https://wdmycloud.local is the same as above if I add :8543 to the end.

In all cases, if I don’t put :8543, then this is what I see…

Have you changed anything on your local network or with your broadband provider since upgrading your My Cloud to OS5? Are you using any kind of DNS or IP address filtering to block ads (like Pi-Hole, AdGuard, etc.)? Does the My Cloud have a fixed, static or reserved IP address on the local network?

As further troubleshooting steps. Have you tried disabling any security/firewall software on the computer? Have you tried disabling all browser extensions or add-on’s?

As indicated by one of the previously posted WD links this is the general process for how HTTPS works:

Additional Information about HTTPS on My Cloud

During Device Setup

  1. When the My Cloud device boots up for the first time in version firmware, the device is registered with a unique device id to the My Cloud database
  2. A DNS entry is created for this device in the My Cloud database
  3. A certificate from Let’s Encrypt is generated for local and direct DNS names

During Admin UI Access

  1. Browser connects to NAS via http://IP
  2. Admin UI is loaded in browser and determines that NAS can be reached over HTTPS
  3. Browser is redirected to
  4. Browser resolves to local IP address of NAS
  5. Browser checks certificate presented by NAS and validates the HTTPS connection
  6. Browser communicates directly with local NAS to perform Admin UI functions

If something has changed, like your IP address has changed, its possible it may break (or broke) the security certificate that was generated which may be causing the errors you are experiencing. Not sure how one can generate a new security certificate or trigger the process to generate a new DNS entry for the device on WD’s end. Maybe one has to do a device reset, either 4 second or 40 second. Or do a restore to factory defaults.

My Cloud OS 5: How to Reset a My Cloud OS 5 Device

My Cloud OS 5: How to Restore To Factory Default Settings

@Bennor - I haven’t altered anything on the network since the upgrade and I don’t believe I’m using any filtering programs. I disabled AVG Free but it made no difference.

I do use a static IP for the My Cloud and I haven’t altered this.

The drive is still indexing the files, taking days.

When I upgraded, I had to change the https to http as I couldn’t access the dashboard. I had previously saved the URL in my Favorites so I presume I must have been using https://wdmycloud originally.

I didn’t want to do a full reset if I could help it as I don’t know that I would be sure I’d remember my settings and I can’t face all that indexing again wth a restore. Maybe I’ll just have to use it insecurely. Seems really strange.

Thanks for trying to help.

What were the steps you did to upgrade?

This link provides the information on what must be performed before updating to OS5.
Find Answers and Discussions (

I followed the steps at Upgrade My Cloud OS 3 Firmware to My Cloud OS 5

However, there was a slight issue in that the box in Step 3 wouldn’t work when I clicked it so I went to the Settings and upgraded through a button there. Also, as I went through the Steps, the text wouldn’t display until after the Upgrade, only the Next buttons etc. would show so I went by the images of the Steps on that page to see what was supposed to be happening. I tried it in Firefox and Chrome and both had the same issue.