not secure?

When trying to login to, it wont connect. It tells me that I need to accept my devices certificate. So I do. Refresh page, and now in my URL bar, it has the HTTPS crossed out in RED with the big bold letters of NOT SECURE. How do I solve this because I don’t remember HTTPS being crossed out in RED.

Using mycloudEx2 with Chrome and IE (all up to date wit most recent updates and firmware).


Could someone at least tell me when they log into if their https is crossed out like mine? Is yours secure and just not mine? Or is NOT SECURE normal for everyone and I should forget about it?


I don’t seem to have this problem.

I have seen this behavior when I am using dodgy networks. For example, when I am using a hotel wifi, and the server is trying to redirect the traffic to a log-on page for the hotel. Most annoying. . . as the browser sees the redirection and closes the connection (before I can log onto the network).

I see they have renewed the certificate as of February 1 2019, valid until March 1 2020.

1 Like

Thanks for the reply — please pardon my ignorance, but is that related or the cause of my issue? My issue seems to have magically gone away and now is back to being https secure…

Short answer: Yes.

An invalid site certificate will cause an error like you describe.

I have the same issue with Mycloud, Chrome says my https is not secure?
I have the latest firmware (2015).
My laptop is up to date Windows 10.
I am a UK user.

The site certificate is valid until March 1 2020, so that is not the problem.

I have reported exactly the same problem, experienced with a MyCloud Ultra EX2, and the tech support suggested that my device was faulty.

I believe it has to do with their latest firmware update, but the tech support does not agree.

The settings on my device and modem router are correct and port forwarding is enabled. The problem disappears when port forwarding is disabled but I cannot use a relay connection for the WAN users without causing the files to be downloaded terribly slowly.

I am not returning the device and see what happens. I bet the problem will be solved with the next firmware update.

I have the same problem with Edge, Firefox and Chrome.
I have just performed a manual firmware upgrade from 2.31.149
to 2.31.174, and the issue still appears.
I have found this problem a few weeks ago accesisng via PC … No issues with My Cloud app for android

I am facing the same issue. If someone has a solution, please let me know. Thanks

In my case, the problem was fixed on its own a few days after updating the firmware, but I think the solution is totally unrelated to the update.

On June 6, 2019, the website returned to being secure and the certificate update – which was requested every 24 hours – stopped being prompted.

I still believe this issue was caused by WD having trouble with Amazon, which issues the security certificates, but WD always refused to confirm it.

I too have the same problem - when I attempt to login to the WD EX2 Ultra - Firefox warns me that the connection is insecure and that anything entered on the web page will be insecure and possibly visible to an unauthorized third party. My PC is running Windows 10 and using Firefox. Both Winn 10 and Firefox are fully updated as is my WD device.

I would appreciate any help in correcting this -

Many thanks in advance