Cant load data from my My Book Live Duo


Today I bought a WD TV PLay, and it looks really great :slight_smile:

The general setup of it went fine, but it seems like I cant read the content from my My Book Live Duo.

I have made several “Shares” on the NAS, all of them is set to “Public” and “Share” is enabled.

I have googled all night, but I cant find the solution to my problem.

Can anyone help me?

As a note to all of this, I switched from a Boxee Box to the WD TV Play, and on the Boxee Box i did not have any problems readning the content on my NAS.

This topic seems to come up a lot for some reason. The Play cannot read network shares, only local media or streaming video from Media Servers (DLNA). It’s not going to see you NAS unless you have it setup as a DLNA steaming media server.

Check out the post below yours

WD TV PLAY cannot find any shared network content

If you want to access your NAS via a SAMBA share on a WD device, look into the LiveHub or the Live SMP

Sorry to say, but worth checking out the specs prior to purchase. It’ll make you life a lot easier

Good Luck



Thanks for your answer.

In my My Book Live Duo, I have enabled “Media Streaming”, shouldn’t that could do it?

See the attached image

What happens when you try to access the My Book Duo and what type of media files do you have on it?

Apparently it worked this morning, I can now stream all of my videos on my TV from my My Book Live Duo via my WD TV Play :slight_smile:

I think maybe that the My Book Live Duo should re-index it all before it worked…

Nice, job, looks like you have it all set up for streaming from your NAS