Can't download Plex Server for My Passport Wireless 4tb

Plex was working fine for me with my 4TB My Passport Wireless until a month ago.
I did the reset and tried to configure the Plex Media Server. I logged in and it told me to download the Plex Media Server.
I selected NAS, then Western Digital, but My Passport is not listed in the download choices.
How do I download Plex Media Server for the My Passport?

Hi raaronson,

Unfortunately, Plex Media server is not available in My Passport Wireless but it comes in My Passport Wireless Pro. If you are using My Passport Wireless Pro, refer below link to get assistance.

  1. I should have been more specific - I am using a My Passport Wireless Pro.
  2. I followed the directions in the link you sent ( I have tried these same steps MANY times). Today, I connected to the MPWP, and clicked on “Media”. It said there was an update for Plex Media Server available. I clicked the download button. It seemed to hang at 50%.
  3. After waiting awhile, I reloaded the page for the MPWP, and it asked for my login. I logged in, and it automatically started downloading Plex Media Server again. Again, it seemed to get to 50% and hang there for a while. This time, the download window just disappeared, and I clicked the configure button for Plex Media Server.
  4. This is where I kept getting stuck last time. A new tab opened up, and the gray Plex background appeared. Then, I got the spinning yellow loading circle for a few seconds. Then, the circle disappeared and the whole thing just stalled on the grey-ish loading screen. I am copying this message in a reply email with a screenshot.
  5. This happens again and again - can’t seem to get past this point. Any assistance would be appreciated.
    Thanks!
    Russ
  1. I should have been more specific - I am using a My Passport Wireless Pro.

  2. I followed the directions in the link you sent ( I have tried these same steps MANY times). Today, I connected to the MPWP, and clicked on “Media”. It said there was an update for Plex Media Server available. I clicked the download button. It seemed to hang at 50%.

  3. After waiting awhile, I reloaded the page for the MPWP, and it asked for my login. I logged in, and it automatically started downloading Plex Media Server again. Again, it seemed to get to 50% and hang there for a while. This time, the download window just disappeared, and I clicked the configure button for Plex Media Server.

  4. This is where I kept getting stuck last time. A new tab opened up, and the gray Plex background appeared. Then, I got the spinning yellow loading circle for a few seconds. Then, the circle disappeared and the whole thing just stalled on the grey-ish loading screen. I am copying this message in a reply email with a screenshot.

  5. This happens again and again - can’t seem to get past this point. Any assistance would be appreciated.

Thanks!

Russ

Update:
I switched to trying to configure the Plex server on my Mac laptop instead of my iPad (which used to work fine, but I’ll move on from that issue).

This time, I was able to log in to Plex while connected to the MPWP 5ghz connection.

It says a server cannot be found and directs me to download a server.

I choose NAS, then Western Digital, but MPWP does not appear in the download list.

Please advise.

Here is an image:

Hi raaronson,

You should contact WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support.