Can't downgrade from 1.06.15 on WD live plus

Since I updated, I’ve had an issue where the unit will almost constantly reboot while an ethernet cable is plugged in. 

The devices and layout of my network at home have not changed at all, and unplugging the cable stops the issue, so I’m convinced it’s caused by the latest update.

I downloaded the downgrade firmware, extracted it to a jump drive, in the root of the drive. I however can not get the unit to show the new firmware available option. I’ve tried starting with the jump drive inserted initially, then Inserting the jump drive while running. Neither worked, so I  tried doing a factory reset and then trying the two previous methods.

When I put the jump drive back into my computer, it’s got an extra folder, .wd_tv, and inside is to files, a wdtv.cas and an MD5 hash of wdtv.cas. 

Any help on getting this downgrade done? I’d like to be able to connect to my network again, I can copy stuff to an external, but that doesn’t get me netflix. 

Thanks for any help.

Make sure you’re downloading the PLUS rollback, not the LIVE rollback.

It’s the Plus rollback, Rollback_wdtvliveplus_release_1.05.04_B (.zip)

Unpacks with no errors, I suppose I could download the release previous to that and see what happens. 

Rolled back to 1.04.31 and no issues. I don’t see issues fixed in 1.05 that would majorly affect me, so I’m going to stick here for a while.