Can't copy large files to USB drive from MyCloud gen1

I’ve spent much of yesterday & today searching for a solution, so I’m not being lazy asking for help.

This week I bought a MyBook 4TB drive so that I could do Safepoints on my 3TB MyCloud with the M-B drive plugged into the MyCloud’s USB port. Every attempt has failed with error 1100 or 1102

I’ve discovered that I can’t copy large files (say 15 GB) through the M-C’s USB to the 4TB M-B. I don’t know if this is the cause of the failing Safepoints, but does seem likely/possible. I’ve tried copying with the MyCloud Desktop app on my laptop & Win10 file explorer. With file explorer I’ve used drive letters mapped to \mycloud\share as well as \IP\share. All attempts fail after several GBs. Win10 progress window didn’t show 0 transfer rates for more than an instant, i.e. only the sort one might expect when one of the drives “needed a breath” to catch up. It seems that thousands of small files copy OK, but I’ve not tested this rigorously.
I’ve tried reboots and shutdown. No effect

I then attached the M-B drive to my laptop’s USB 3 port & used Win10 file explorer - success. I’ve now copied several 20+ GB files and tens of thousands of smaller files at speeds up to 100 MBs (not Mbs) on large files although ~1 on masses of smaller. Around 800 GB and 500k files total.

Win 10 pro
EDIT: should have included Win 10 is x64
My Cloud 3 TB gen 1, firmware up to date, Dec / 16 ver 04.04.05-101
My Book 4 TB brand new, bought this week
Laptop attached to modem/router by WiFi first, then switched to Gigabit ethernet
M-B 4TB connected to laptop USB 3 port, With MyCloud via USB 3 cable included in box
M-B came formatted with exFAT. I formatted to NTFS for compatibility with M-C.
Disabled DLNA and remote access in MyCloud

I’m not familiar with linux at all, so the SSH based possible solutions I’ve read aren’t any use to me. Even if they would solve the problem.

Any suggestions that would get my toward a “normal” Safepoint would be appreciated.
TIA

regards
RDL

Hello,

I recommend you to contact the Western Digital support:

Thanks for the reply. I will do that but haven’t got around to it yet.
Just been very busy & the urgency reduced. I’ve started using Acronis for backup & have worked out a method to back up MyCloud to the USB attached MyBook.
I would though still like to be able to copy or move very large files from the M-C drive to the larger USB attached drive.

regards
RDL