Can't connect to drive


I’ve been using my MBL 3tb for nearly a month and after some initial problems everything was working fine until a few days ago when I couldn’t connect to the drive at all. Even when I try to access the dashboard the web page won’t load.

The LED on the front was orange for just over a day, then became red so I disconnected it completely.

I tried it again this morning and it went to orange again. I have tried resetting it, unplugging it and tried it through my router and wi-fi extender.

I’m thinking I need to update to the latest firmware but I can’t access the drive at all and am pretty frustrated!

Does anyone have any ideas on how to fix this?


The hard drive seem to be faulty, call tech support to replace it. 


I am new to this and have no idea about the technology.

I have a 3TB WD2 GO my book live. I seem to have lost all connectivity to it. 

My laptop shows the drive a Z but can’t access it and my Mac can’t find it at all. My android mobile says it has a network connection failure (907)?

I have a green flashing light on the back and also an amber light. The light on the front is flashing green as well.

If anyone can assist with very easy to understand non tech solutions, I would be most grateful.




need assistance – WD MBL (2T) does not appear in Win.

OS: win xp 32 sp3

connection: local PC – router – WD MBL

action taken:

port forwarding & ip were assigned in router

static ip was assigned in WD MBL

ping is Ok

workgroup – PC / WD MBL

WD MBL accepts web-connection

please help!


solved - on local PC the service «Client for Mivrosoft Networks» was activated (check box was ticked)! For unknown reasons it was OFF.