MBL not visible on network since firmware update to 02.42.03-027

Since updating my 3TB My Book Live to the latest firmware on Wednesday it has disappeared from my network.

I can connect to the web console and this tells me the drive is healthy and the diagnostics said everything was OK.

My Net View also reports that the drive is healthy.

If I run the setup program this recognises the drive but then reports an error saying I will not be able to read/write to the drive.

I did eventually get it to connect on Thursday after leaving it powered down for a while.  Long enough for me to be able to backup my essential data.  But since then it has reverted back to the error described above.

The LED on the front has never worked properly and hasn’t worked at all for at least a year.  The drive was purchased some time in 2011.

Has anyone else had isues since the latest firmware release?

Hello, have you tried connecting the My Book directly to the PC to verify if the same problem happens? You can also try pressing the reset button on the back of the My Book for 4 seconds. 

1 Like


I’ve tried resetting the unit.  Have also tried connecting direct to PC, direct to router instead of switch, swapped cat 5 cables and  disabled bitdefender software etc.  Same issue every time

Strangely, I can connect to the drive via the android WD2go app and play files from the public share, so I think the actual disk is fine.

If you have another copy of your important files, another option would to do a factory restore from the My Book dashboard. Check page 69 of the manual for the steps. 


1 Like

WD Support had already advised doing a quick factory restore.  This failed to resolve the problem.  They then suggested the drive would need replacing.

As a last resort I did a full factory restore and this appears to have resolved the issue.  Not sure why.

I’m not entirely confident that it is 100% though as it will often lose connection and I have to restore the connection when I reboot my PC.

I’ll see how it goes over the next few weeks.

Thanks for the advise.