Can't connect the My Cloud with via chrome


when I try to connect to the My Cloud through via Chrome I get the following error:

Der öffentliche Ephemeral-Diffie-Hellman-Schlüssel des Servers ist unzulänglich.


It says that there is some kind of problem with the ephemeral-diffie-hellmann-key.

It works when I use the Internet Explorer. So, it seems to be a problem of Google Chrome.

Does anybody have an idea which settings I have to change in Chrome to get it working?

Thanks a lot!

Also see p19 of the English user manual. Interestingly, this discussion isn’t present in the German user manual… There’s a whole section about ‘Installing and Accessing the WD My Cloud™ for Desktop App’ that is simply not present, and it jumps straight to ‘Getting Started Without the Online Setup Installer’ (‘Erste Schritte ohne das Online-Einrichtungsprogramm’).

The Spanish manual appears to be identical in content to the English…

Thanks a lot for your reply.

I’ve already seen the links you’ve copied. But it doesn’t solve my problem.

I have access to the My Cloud through the Desktop App.

But the problem is getting access through via Chrome. Every time I try I get the error mentioned in the first post.

Does anybody have an idea how to get the website work with Chrome?

The following may or may not help. It appears Chrome finally cut off support for one form of Java (NPAPI) as they indicated they would last year. Because the WD2Go site uses Java those who use Chrome may, potentially, no longer be able to access their WD My Cloud and supported other drives remotely. One can either use another web browser or can perform the following setting changes to Chrome. Note: you do so at your own risk.

Enabling NPAPI in Chrome Version 42 and later
As of Chrome Version 42, an additional configuration step is required to continue using NPAPI plugins.

  1. In your URL bar, enter: chrome://flags/#enable-npapi
  2. Click the Enable link for the Enable NPAPI configuration option.
  3. Click the Relaunch button that now appears at the bottom of the configuration page.

See the following links for more information on this Java/Chrome problem:

Download Java for Windows

How do I use Java with the Google Chrome browser?

Enabling NPAPI in Chrome Version 42 and later

Just got my EX2 and I’m really sad to hear this. I usually send shared links of some files to friends and because of this issue I am required to tell them to use IE (even Edge doesn’t work).

WD should fix this instead of requiring another browser (found it on the knowledgebase).

By the way, Chrome 48 doesn’t allow me to enable NPAPI.

Edit: Turns out WD fixed it already… Now the problem is any browser running an adblock. Anyone?

Not sure what your question is. I use AdBlock Plus on all my web browsers (Internet Explorer, Firefox, and Chrome) across multiple computers and don’t have a problem logging into and using web portal or the WD My Cloud Dashboard user interface.

It seems that’s what most people use. I was using uBlock and I had to disable it for that website for it to work.