Can't connect (again, after firmware update)


I’ve got a my book live 1TB for a couple of months now but I have a problem.

5 computers are connected with it (2 of which are laptops) and sometimes some of them simply can’t connect to it. Then I have to wait a day sometimes longer to get it working again, I don’t think I can do something about it since I’ve had this problem before with the firmware before my previous one.

So the first firmware (the one that came with the device) worked flawlessly, the second one had the connecting problems, the third one also worked flawlessly and now the fourth (latest) again has connecting problems.

Now my question is, is this is known ‘fact’? If yes will there be some minor update to fix this? Because it’s quite annoying when you’ve paid 180 euro for something which you can’t use :S

Oh can there something be done about this (I know I said that I’ve tried ALOT of things, but you never know)


What you have described is a random power that can happen to anyone regardless of the firmware

don’t think it’s a firmware issue 

Make sure the firewall or internet security is not blocking it

the fact that is working on other computers lets you know that the drive just works

you have isolated the problem to some computers so there’s some configuration there that needs to be check 

Thanks for the reply

I haven’t exactly isolated the problem on some of the pcs because sometimes it’s my main computer which can’t connect the day after that my main computer can connect but then my laptop can’t. (or my laptop can but main can’t …)

So I do think it’s a firmware issue because it didn’t occur once with the previous version but anyway. Can anyone point me to a thread which explains how to rollback the firmware?

My experience with connections is that MBL is flakey regarding a connection to my avr.  Sometimes it works & sometimes it won’t even wake up MBL from the blue sleep state; I just use the reliable pull the plug from the switch box & then plug it back in.  When the led was green, after the unplug it used to go to red, cable disconnected; now it reboots showing the white/amber led; on occasional blue, there is no response when unplugged if the led is blue.

Then last night, I notice that the mapped MBL was showing disconnected in win7; win7 didn’t have a “connect” as an option for the drive!!  Interesting even if there was a red X on for the MBL, I was able to get to it by just using the mouse & clicking on it which, I guess, also reconnected it.  The MBL was in the blue condition so don’t know if that was how things work; will try to remember to check on that condition when the MBL is in sleep mode.

Guess sometimes the MBL is a “late sleeper”?