Cannot connect at all, spent hours trying everything I can think of

After a month 2Tb My Book Live is no longer to connecting to my router, I have tried everything I can think off, the router is fine, DHCP is working, The TV, Blu-ray Disc Palyer, PC etc are all connected fine.
There is a green led at the front of My Book Live, I have tried resetting it, the led at the bottom of the ethernet port is green, when I try to connect directly to my PC the light turns amber.  My last hope seems to be connecting directly to my PC but how do I do this exactly?  I just cannot access it.  I now seem to have a useless, but expensive, piece of plastic & metal junk!
Please help!!

This is exactly the same thing that is happening to me. Everything was working fine before I disconnected the drive to decorate. Now when I plug it back in to the router, the router does not see it at all. Going by the lights on the my book it thinks that it has a connection. But the router (I have tried two and they both work with other equipment) says otherwise.

Not hijacking your thread just sounds like the exact same problem.

what IP is your router assigning to the MBL?  Have you tried typing that IP directly into a browser?  Recent firmware release have dealt with some dhcp issues but I still reserved one particular IP for the MBL.  And make sure you have the same workgroup names

You can just plug the MBL right into your PC’s ethernet jack, it’s auto-senses a direct connection.

Thanks for the reply, I not that hot on networking.  The router used to give to MBL but not anymore, connecting directly to my PC does not work, I’m stuck.

I give up, after one month of use I wasn’t impressed, slow transfer speeds & couldn’t stream many of my videos, now it’s failed completely, £160/$240 what a waste, I will steer clear of Western Digital, never had any trouble with other makes, what was I doing buying this junk?

Have the same problem, purchased a My Book Live 3TB 3 months ago, worked fine, was transfering some files and then suddenly it disconnected. Tried pretty much everything, If I unplug it and wait a minute it reconnects but then drops out, the router (2wire via AT&T) can not see it as well. When the MBL is rebooted, I get a blue light then a steady green light, but no network.