Cant access dashboard windows 10

I cant access the dashboard. I have tried the reset button on the back to factory reset and the notifications say that it has been factory reset but I get incorrect username and password every time.

Seems to be a common problem. See my thread above on same subject. No word yet of any solution…


I will call support tonight if I have time or it doesn’t magicaly fix itself. For some reason I can get the dashboard through the ip address. And I can read and write to it fine. I Uninstalled the software and now the setup doesn’t see it. The first time it at least let me put in mac address now I just get not found.

Have you tried to use http://wdmycloudmirror? This will kick you straight into the Web UI of the My Cloud Mirror.

In my case… I HAVE tried going to wdmycloudmirror, and it asks for a user/password and rejects everything/anything that is entered.

In fact, it says ‘incorrect user/password’ before I have entered anything!


Well I was afraid this would happen… It just magicaly started working. It did become unreachable for a time today until I power cycled it. But I think that has to do with a problem I’m having with my router.

Hi @Neil_Woodbury

if you are asked for credentials, then there are credentials stored. If you don’t know the credentials anymore, you should do a reset-to-factory-defaults (holding the reset for 40 seconds during boot up).

In factory stage, you have to create at least one user with nickname, name, email address and password before you were asked for credentials.


this may be caused by some energy saving methods that cut off the switch port(s).

I did the 40 sec reset…it did not work.


OK…I DID manage to solve this. I read on another forum (for a different WD device) that they had to power off the system and hold down the reset button while applying power, and hold for 40+ secs, and that this would reset the unit to ‘factory defaults’. The catch was…it also is supposed to erase all current data.

So…on my unit, it is only 1-2 days old and hence I have nothing on it I cant lose…so I tried this…and…IT WORKED. Full access restored…brought up dashboard and immediately set a static IP. And the good news…IT DID NOT ERASE ANY DATA. (but beware if you try this!)

So now I have full dashboard access…have updated the firmware…mapped drive on win10…all seems good.


Ah, sorry, undrestood! Next time I will write it this way to avoid misunderstandings. And, no, data will not be deleted! This would only be the case if you do a “Full System Restore” from within the web interface.