Cant access dashboard-login rejected

Got new 8T my cloud mirror. Performed web based setup, no issues. Did some file transfers via web. No issues. Installed PC app ‘WD My Cloud’, performed more file transfers with no issue. Tried to access ‘dashboard’ (via web as per support page) and get ‘The user name or password is incorrect’. I get this no matter what I use for a user name (my login, my name, my email, admin, etc…)
Called tech support and they had me change numerous windows settings (I am on win 10), but still same result. Tech support said I needed to ‘elevate issue and should call back tomorrow’. I have tried firefox, edge and even a different computer with IE. All have same result.

The web login screen states ‘the user name or password is incorrect’ before I have even typed in anything!
Also…note that I have tried both the short (10 sec) and long (40+sec) resets and it did not change anything.

I was trying to get into the dashboard so I could set a static IP on the device. Now the IP has changed and I cant even get the ‘WD My Cloud’ app to connect. I can ping the unit just fine…

sigh…any / all help appreciated! Not looking forward to 2 more hours on tech support…


Hi, I Have the same problem that you. I an not login to the dashboar by the app or by the web.
By the app it apears a text that said that the divice is not connected to the network.


Hi, I also have the same problem, I can access the drive from my computer, write and read files via a mapped drive, however if I load up WDmycloudmirror it cannot find my drive on the network at all - even though I can see it as a mapped network drive. I have only had it 24 hours and cannot get past this issue - if anybody else has had this issue please can you advise on how you got past it?

Andres & David…did either of you contact WD Tech Support?

OK…I DID manage to solve this. I read on another forum (for a different WD device) that they had to power off the system and hold down the reset button while applying power, and hold for 40+ secs, and that this would reset the unit to ‘factory defaults’. The catch was…it also is supposed to erase all current data.

So…on my unit, it is only 1-2 days old and hence I have nothing on it I cant lose…so I tried this…and…IT WORKED. Full access restored…brought up dashboard and immediately set a static IP. And the good news…IT DID NOT ERASE ANY DATA. (but beware if you try this!)

So now I have full dashboard access…have updated the firmware…mapped drive on win10…all seems good.


I’ve had the same problem with a new MyCloud Mirror Drive. Press & hold reset for 40s while powering on also worked for me. Full dashboard access enabled, access through Finder (Mac OS) across network. Accessed via Safari (web) and ip address, the unit then went through a setup process to set up a new Admin Account - then I could log on OK.

I seem to be having a stale-mate with my WD MyCloud Mirror Gen 2 4 TB unit. Perhaps your applied solution is my solution as well?

I am therefore wondering, cause I have just unplugged my unit and held down the reset button on the back of the unit for 40 seconds (or more): What will the LED-indicators (lights) on the front do, to show that this major reset has been applied successfully?

Cause what I get now is HD1 LED is blinking constantly, as if the harddrive is “working”, as soon as I try to log in to the dashboard though my web browser… :frowning: