Cannot web access to my cloud files

Içm trying to access using different web browsers con the laptop and it´s impossible to access today. Nevertheless, the web access is working on my mobile phone. Could anyone help me to understand what is happening?

Thanks in advance.


It appears there are problems accessing the web portal using a web browser. Another user reported access problems with the web portal earlier today:

Same issue cannot login tried Chrome, Edge and Explorer. Getting old always having this issue. Does anyone know of a better product out there?

I’m having the same problem since yesterday used Chrome Mozilla even Explorer and none of the work.

@ceciprocel please clear your browser cache and then go to, click “Sign In” and it should be fine.

I tried ir and still doesnt work I changed muy Smart phone and can’t get to my cloud either

Same problem on my side. I cant login via Chrome Browser.
See only this message…

Edge not supported. MyCloud on Android phone works correct. Comon WD - repair it!

I was also getting this message I found a post about this someone had a adblocker on and they told them to turn it off for that site. I myself also had a ad blocker on i turned it off and i was able to sign in.

Thank You!!! It works. Thank You very much!

I have had the same recurring problem for the last 2 weeks. I’m thinking of ditching the drive and purchasing something that works properly.