Cannot open Dashboard

I have only just got my new MyCloud 4T storage device and cannot access the dashboard no matter what I try. Please can somebody help?
Thank you.

What have you tried? What operating system are you using? Is the front LED blue?

Generally one can access the my cloud using http://mycloud in their web browser. Or they can try using the IP address for the my cloud in their web browser. For example One can find the IP address of their My Cloud via their router/gateway’s DHCP server administration page, or via Windows File Explorer > Media Devices / Storage Devices > Right click and select Properties > IP Address.

Hi Bennor. Thank you for replying. I am using Windows 10. I have tried both the IP address and the url method and all I keep getting is a user login page. I have tried logging in but it keeps saying its only for administrator. I am able to upload photo’s etc. from my iPhone and iPad but I cannot get to the dashbord. I have tried my laptop, PC and my iPad with no success.

To access the Dashboard via a web browser when it has been configured for Administrator access you need to use the Administrator User Name and Password. If you lost the Administrator User Name and or Password you can do a 4 second reset which should clear the Administrator password. See the following WD Support document for more information on how to reset and what a reset does:

I have done a reset on the device but I still can’t access the dashboard. That page still keeps coming up looking for a user and login. Anything that i input does not work including not inputting anything. It keeps saying that “Only administrator users are allowed”. I also tried running the setup program again but now it can’t find the device even though it did when I first set it up. Should I try a Restore?

Actually Bennor, I have the same problem (same device, mycloud 4TB) as Tom
But I don’t think it’s a thing about reseting the device.
I’ve opened a Ticket, describing the problem.

To be a little more technical:
Windows 7 User,
Static IP assigned to de drive (outside the DHCP range of the router), no conflict with others devices in the network.
The drive is mapped, correctly (i’m copying data right now), but i cannot access the dashboard or My Cloud service.
I think there is a problem with the web server service (or it stopped by itself or crashed) of the linux mounted in the device.

Would I be right in thinking that it is a network/router problem rather than a Windows problem bearing in mind none of my devices can access the dashboard?

If you see the drive in your network, then it’s not the router or your pc (even if you cannot acces the dashboard).
Question: what do you mean with cannot access the dashboard?

You see the login page and cannot enter or see s connection error (you don’t see the login page)

I see the Login page asking for a user name and password. I can see the mycloud device on the left side of windows explorer under Network and when I click this, it gives me about four of five folders. The “Public” I can access but the one that says “Mycloud” comes up with another box that tells me to enter network credentials.

What does the screen look like that prompts you for a user name and password? You should be seeing the following screen in the web browser if you are prompted for a password.

That’s the screen alright. But it doesn’t say “No password created” like this. Both fields are blank.

You access the Dashboard using a web browser (Internet Explorer, Edge, Firefox, Safari, Chome, etc.). If you are using Windows File Explorer to view the contents of the My Cloud (the Shares) you are NOT accessing the Dashboard… See the “How to access the Dashboard on a My Cloud device” link above for more information on how to access the Dashboard using your web browser.

Like I said before. I have tried both ways to access the dashboard including "http://wdmycloud/

I also installed WD Quick View. This lets me see that the device is working grand and that the temperature is good etc. It also has a Dashboard button which when pressed, brings me to that login page again.

Did you previously create a password and or change the name for the default “Admin” account on the My Cloud?

If you haven’t changed the default name of “Admin” then use that as the User and enter in the password if one was previously created.

I did originally create aa password and I changed the name to Mycloud, but this did not work when I entered them. I have since done a reset on the device so I assume this action reset the name and password?

Thanks a million for the help. I tried the original password and user name and it worked. Problem solved. Thanks again.