Access to Dashboard No Longer working from my main PC


I am a new user and have been successfully uploading files from my iPhone and my wife’s iPad to our MyCloud.

However, in the past days, it seems it is not possible for me to access via my desktop shortcut (or otherwise) the my cloud dashboard the my cloud public share.

Its strange because it was working fine 2 weeks ago when I first did my initial set up.I did update the firmware based on the myCloud dashboard recommendation about a week or so ago.

But now I cannot get to any of the admistration views that I want for getting further acclimated to the product.

I CAN upload content to the cloud successfully, and also play back the content from different devices wiht the app installed, but CANNOT get to the dashboard or get to the various folders from my I receive a connection timed out error

Hello there.

Do you know the IP address of the unit to see if you can access the dashboard through its IP? If you are using windows you can check on the windows explorer and on the network section you will see 3 categories or 4 you will right click on the that is located under the storage category and once you right click go to view device web page. You can also try t go to your Web Browser and type “http://the name of the drive or the name of the drive.local” and you should also be able to see the dashboard. In case this does not work try resetting the unit by pressing the button on the back, this hole shaped button id on top of the Ethernet plug, you should press it with a paperclip or a pin for 3 to 5 seconds.

Here is a link that might help with the reset process:

I would give a “System Restore” a try … it has worked for me in the past when I had issues like yours. Especially after a firmware update.

Uplug the unit and at the same time as the power is plugged to the WD My Cloud device, pressing the Reset button and holding it for about 40 seconds, will make the device to go through a System Restore instead of a Reset. This System Restore will not cause data loss, and all Private Shares will become Public Shares.

Sometimes you have to be a contortionist to accomplish this … lol

Thank you for the suggestion to simply use the name of the drive this seems to have worked.