Cannot map WDMyCloud Network Shares in WD Discovery

Windows 7 64

WD MyCloud 2 TB

FW - v03.04.01-230

Router Buffalo WZR-HP-G300NH

Everything had been working perfectly for some months until I had to recently swap out routers. (Long embarrassing story about a bricked router that I won’t go into).  I attached an identical router, reconnected the WD MyCloud and everything seemed fine until I realized I cannot map the drive in Windows. Previously I had successfully mapped the shares.

I can access WD MyCloud through the dashboard

Remote access is working

I have set a fixed IP in WD MyCloud

I have rebooted it and powered it off/on without effect

Network Discovery is ON

SSDP Discovery is Started, Manual startup

WD MyCloud shows under Storage in Windows Explorer but clicking on it does nothing

Trying to access via \WdMyCloud yields a “Windows cannot access” error

Doesn’t seem to matter whether I am using Windows Home Group or not

The WD MyCloud shows in WD Discovery but the “Map Network Share” button is greyed out.

Anyone have any suggestions?

Thanks…Steve

1 Like

OK, I have finally solved this. It turned out to NOT be a problem with the WDMyCloud but with the networking setup on my PC.

After lots of digging, I discovered that when I went to Networking and Sharing Center --> Change Adapter Settings  --> Properties that the Client for Microsoft was not present for some strange reason, so I installed that.

Following that, the solution posted  HERE solved the problem. This solution, and a ton of others, had not worked prior to installing the networking Client for Microsoft. How or why it disappeared from the adapter properties is beyond me but it doesn’t matter at this point.

:smiley:

1 Like

When you swapped the router, I’ll bet you the first time your PC detected the new router, it asked you for a network profile type, and you might have given it the wrong answer. Options are like Home, Work, Public, etc. the configurations are different for each profile type.

I am certain you are correct. When the Windows dialog box pops up asking you to choose a network profile type, I believe Public is the default. I suspect I inadvertently “selected” Public rather than Home. Normally this wouldn’t be much of a problem, I don’t think, except that somehow the Client for Microsoft network had been deleted. This probably happened as a result of all the machinations I went through attempting to recover the bricked router. Once the Microsoft Clilent was installed, it was a simple matter to switch the network profile from Public to Home, which allowed WDMyCloud to appear normally in the network list.

Steve511 wrote:

…except that somehow the Client for Microsoft network had been deleted…

That’s correct.   IIRC, Client for Microsoft Networks is not enabled for Public profiles.

http://windows.microsoft.com/en-us/windows/choosing-network-location#1TC=windows-7