Cannot get Windows 10 Pro to install on my SN550 NVME 1TB SSD mounted on PCI-E m.2 adapter

I can’t get the Windows 10 OS to install on my WD SN550 NVME 1TB SSD mounted on PCI-E x4 M.2 adapter. I get error that Windows cannot find required files to install (Please check the screenshot). After trying to reinstall Windows 10 second time after getting error install window shows no drivers listed. I have unplugged all my HDDs and trying to install only on NVME SSD. I tried disabling “Fast boot”, CSM and Secure boot and enabling CSM later but in vain. I even tried changing USB drives, tried installing from a latest fresh release of Windows 10 USB drive directly downloaded from the internet.


Does your BIOS show the SSD?
If you are using a USB3 port for the install media try using a USB 2 port if you have one.

Maybe you should buy other SSDs, like Samsung SSD, it might be caused by the standard Windows 10 NVMe driver [stornvme.sys]. according to this link: WD_BLACK SN750 NVMe stops working until reboot

I got the same error code today after putting the SN550 to a pcie adapter and wanted to initialize the storage with a partition table - WD Dashboard and BIOS were both happy about the new nvme card.

Seems to be a windows problem - reason unknown yet.

What helped for me was - as I do have a dual boot system - I did boot my linux, put a gpt partition table there and a new partition formatted with ntfs - both worked flawlessly without any error there.

After a reboot Win10 Pro was happy to work with the nvme.

Maybe you can do the partitioning with a linux live cd / usb stick and use it like that afterwards for installation.

https://youtu.be/FwJ5wLbEXcA - see maybe this can give you ideas, worked.

Usually the BIOS is configured to use M2_1 for the M.2 NVMe SSD for the system, add in cards etc do not support boot unless there is an option ROM attached for the UEFI to select