Cannot Format


#1

Hello all,

I just bought a brand new 8TB WD easystore external hard drive. I installed it onto my Mac properly, but when I tried to format this drive to make it writeable, an error screen says there isn’t enough space available for this to occur. I tried erasing it to reformat it as Mac OS Extended (Journaled), and the message says “Unmounting disk. MediaKit reports not enough space on device for requested operation. Operation failed…”

“disk2s1” now appears in grey in the sidebar where “easystore” used to be in black. I’m running 10.13.2 High Sierra. I’ve tried partitioning the drive into 7.75GB/0.25GB. Perhaps this is an easy fix but I feel like I’m going insane and I don’t know what to do. Please help!

Mount Point: Not Mounted
Capacity: 8TB
Available: Zero KB
Used: –
Type: USB External Physical Volume
Owners: Disabled
Connection: USB
Device: disk2s1


#2

I bought a brand new WD Easystore portable 2 TB HD in October, 2017, and just now, 5 January,2018, opened the package and tried to use with my iMac 5k Retina 27 inch, Late 2014 desktop computer, also running OS 10.13.2.

I am getting the same fail message you are - “MediaKit reports not enough space on device for requested operation.” This should not be the case as my iMac drive is 1.1 TB and is only one third full. This came up with Time Machine, but then Time Machine doesn’t see the HD. Using Disk Utility the HD shows as disk3s1 (yours is disk2s1). Nothing works trying to erase the disk - not the proper Mac OS Extended (Journaled) format or any other formats erase, although it opens a box that says it is erasing.


#3

I have had the exact same problem this evening. Also running 10.13.2.


#4

OK, here’s what fixed this for me.
Open Disk Utility (not in Recovery Mode) and change the View drop-down (upper left corner) to Show All Devices. Then select your actual device - not the indented volume - and then the Erase making sure the Partition Map Scheme is GUID and format is Mac OS Extended (Journaled). This should recreate your single volume as GUID/HFS+.


#5

Here’s is what fixed it for me. I was able to use Disk Utilities on an older OS. I tried OS Yosemite and the configured using the partition instructions.


#6

Try this link