Formatted to windows but Need to reformat to Mac help


#1

Hi,

I have a WD essentials 1tb external hard drive formatted to windows 7.
Currently I store about 64gb of an iTunes library on there.
I’ve just bought my first Mac and understand that’ I now need to reformat the disc to Mac.

I am a complete novice and need help in obtaining an idiots guide to this process otherwise I’m in danger of losing all my iTunes.

Can anyone help?

Cheers

Scott


Cannot Format
#2

Are you planning to use your WD Essentials for both Windows and Mac?

  1. If you use for both Windows and Mac OSX then you can backup your data on the device on to Windows and then format the device as ExFAT then copy the data back on to your device.
  1. If it is just use for Mac OSX then you can plug the device to your Mac then copy the data on to your Mac. Use Disk Utility to format the device as AFP. When format is done then you can copy the data back on to your device.

#3

Not sure if this is the right place. However, have a new HD but am not able to format to allow me to save files from my mac.

Anyone help?


#4

Have you try to follow the link above?


#5

yes I have. thought it were a faulty HD so went out and got another one only to have the same issues. the product is a WD Elements1TB basic storage. Its default NTFS and I am trying to format it either ExFAT or Mac OS Extended (Journaled) but not getting anywhere…


#6

Where is your problem at? If you follow the link you should be able to format the drive. Let me know where you are stuck at so I can help you.


#7

Was stuck at the beginning. Plugged it in, followed the instructions and kept getting “Operation Failed”. Tried partitioning the disk (ExFat)… same message “Operation Failed”. Tried partitioning again (Mac OX Extended - Journaled)… only for the disk to rename itself to disk2s1. Now every time I plug the disk in to my pc I get the message “disk not recongnized” and I am promoted to either initialize, ignore or eject. Tried initializing but nothing changes.


#8

Oh, I got it. I got the error that Mac OSX doesn’t like the device that has already have MBR/GPT table. I have a script that can help that issue. I’ll find it or find a command solution for you. Hang in there.


#9

Cheers. Very much appreciated.


#10

Oh my gosh, I am having the exact same issue. I just bought a WD Easystore 2TB external HD and tried to partition it for both Mac OX Extended Journaled and ExFAT and both operations failed and now it changed the name of my drive to disk2s1 and it won’t mount. When I plug it in the computer says it does not recognize the disk. HELP, I just got this yesterday. I only want to use mine on my MacBook. I had the identical process as the original poster.


#11

Yeah, I cant get past the current situation. Having to return a second HD to Amazon in 2 days. Pretty frustrating.


#12

My amazon doesn’t sell WD drives, only Best Buy does. I’m returning mine and already bought the WD Passport 2TB drive which comes already formatted for MAC. Hope that solves my issue.


#13

@jebusx any way you can share that script or command solution? I’m getting the same error message “MediaKit reports not enough space on device for requested operation. Operation failed…”


Can't format for a Mac ( ; - (
#14

FormatDrive.txt (2.7 KB)

OK, I found it… Make sure to unplug every other external device as it will format those too. Only attach the device that you wish to format. It will format everything on the device and create a single partition. Hopefully you back up everything before you run the script.

To run it, open Terminal app

type "sh " drag and drop the file in to the terminal window then press Enter key.
Just sit and wait for
“Mounting disk - - Finished erase on disk1”

Hope it help. It work for me before. I haven’t test it since OSX 10.12
Let me know if you encounter any error.


#15

Cheers… Went to the PC store and picked up a new disk. Avoided the previous brand only for the same thing to happen. GRRRRRRRR

Slightly PC illiterate… so I type “sh”… correct?

And then drag and drop which file into the terminal window.

Apologies…


#16

Should have paid the extra $100 for a ready formatted HD. But then it would need formatting & partitioning to allow Windows…

Really really frustrating.


#17

Well I returned the WD that I had purchased and bought the WD Passport which is already formatted for MAC. Plugged it in and started using it, no work required. It was the same price as the first one I had purchased. They shouldn’t say that one can be used with MAC because it can’t.


#18

Tried to get the guy at the PC store to format for me. Had my laptop there and everything. He wouldnt touch it. Now I know exactly why… 3 HD’s later and no progress made.


#19

@new-2-WD-Mac were you able to resolved the issue? Found the solution, very easy solution by mistake. If you havent found the solution do the following…

when opening disk utilities, select the disk in the left hand pane, then click the “view” icon just above the “internal” mark and ensure that “show all devices” is displayed and then start the process again… “erase” blah blah… and then “partition” if required.

hope it helps…


#20

Tried doing what other people said to do but nothing worked till I saw this way to do what needs to be done. A couple of clicks and I was on my way. Thanks Mitch2708