Tried Reformatting WD EasyStore 2 TB for Mac... Didn't work


#1

Hi,

When I first plugged in my new WD easystore 2 tb portable drive, I installed the necessary software off the drive. After doing so, I was still unable to utilize the drive (unable to create new folders, drag/drop anything). I then tried reformatting it by erasing and setting the format from Windows NT File System (NTFS) to Mac OS Extended (Journaled) for my macOS Sierra (Version 10.12.3). The erase was not complete because the disk was unable to mount.
After a few minutes, I realized that the drive was no longer being recognized by the mac and unplugged it and plugged it back in only to get this message:

When I open Disk Utility, it shows this:

What happened?
How do I fix this so that I can utilize my hard drive?

Thank you so much!


#2

Hello,

Try replacing the USB cable of connecting it to another USB port.


#3

Did you ever get this resolved? I’m having the same problem


#4

Same issue as well. This is the third drive I have tried, I need a solution or I will have to switch to another company. Never had this issue before. Drive wont format in either Time Machine or Disk Utility, reads “disk1s1” it is unmountable. Every action fails. Help WD, asap!


#5

I have this exact same issue! I bought the easystore 2tb portable backup. Model wdbkuz0020bbk-wesn


#6

I was having the same problem but finally found a different thread that helped… Don’t use the Mac Disc Utility. Instead use the WD Disk Utility. Fixed the problem in about 30 secs.