Can not erase or partition new 8T EasyStore for Mac

I am trying to follow the directions for my new 8T easystore to have it work on my iMac and I can’t get past the “Erase” Step. The one option it pre-selects is grayed out and does not match the directions. What else should I pick from this list since the step by step directions don’t indicate anything? I’m running High Sierra.

If you want dual compatibility between Windows and Mac, choose ExFAT.
If you have no need for that, then choose whichever Mac OS option fits your needs.

I’m having the same issue.

I’ve tried to hit ExFAT and erase over and over but all it’s doing is dismounting my HD.

Still getting nowhere with this. I am choosing ExFat in the erase section but I keep getting the same error message “MediaKit reports not enough space on device for requested operation”

I needed this hard drive right away. I’m about ready to just return it since it is currently unusable to me. I have two 4T My Books for Mac that I have loved and have worked perfectly from day one. So far the “easy” store has been the opposite of easy!

1 Like

This post was flagged by the community and is temporarily hidden.

This post was flagged by the community and is temporarily hidden.

I am trying to post the solution to this but WD “Community” or the robot is flagging the post. Because solving the issue is not ok apparently. Anyway… I can solve it for you. Go to wdc.com, select your product, download the driver for Mac WD Utilities, install and erase the drive and format to HSF+J.

1 Like

Thank you! I will try that!

Can’t imagine why that post is flagged, but it is visible if one selects to view it.

Mac OSX tend to have problem formatting Windows devices with (MBR/GPT) table. I have a script that help to ease Mac OSX users with these kind of problem. Or try to use WD Disk Utilities as someone mention the post below. WD Disk Utilities as I know does not offer to format the devices as NTFS. It only offer to format as (APFS or ExFAT).